发布时间 :2006-01-17 20:51:00
修订时间 :2017-07-19 21:29:26

[原文]Unspecified vulnerability in in Albatross web application toolkit before 1.33 allows remote attackers to execute arbitrary commands via unspecified vectors involving template files and the "handling of submitted form fields".


        Albatross Web应用程序工具箱1.33之前版本的context.py中存在未指定漏洞,远程攻击者可以通过与模板文件和"处理已提交的表单字段"有关的未明向量执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  16252
(UNKNOWN)  VUPEN  ADV-2006-0196
(UNKNOWN)  XF  albatross-context-command-execution(24130)

- 漏洞信息

高危 设计错误
2006-01-17 00:00:00 2006-01-18 00:00:00
        Albatross Web应用程序工具箱1.33之前版本的context.py中存在未指定漏洞,远程攻击者可以通过与模板文件和"处理已提交的表单字段"有关的未明向量执行任意命令。

- 公告与补丁

        Albatross Albatross 1.20
        Debian python-albatross-common_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge oss-common_1.20-2_all.deb
        Debian python-albatross-doc_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge oss-doc_1.20-2_all.deb
        Debian python-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge oss_1.20-2_all.deb
        Debian python2.2-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge atross_1.20-2_all.deb
        Debian python2.3-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge atross_1.20-2_all.deb

- 漏洞信息 (F43249)

Debian Linux Security Advisory 942-1 (PacketStormID:F43249)
2006-01-21 00:00:00
advisory,web,arbitrary,code execution

Debian Security Advisory DSA 942-1 - A design error has been discovered in the Albatross web application toolkit that causes user supplied data to be used as part of template execution and hence arbitrary code execution.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 942-1                                        Martin Schulze
January 16th, 2006            
- --------------------------------------------------------------------------

Package        : albatross
Vulnerability  : design error
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2006-0044

A design error has been discovered in the Albatross web application
toolkit that causes user supplied data to be used as part of template
execution and hence arbitrary code execution.

The old stable distribution (woody) does not contain albatross packages.

For the stable distribution (sarge) this problem has been fixed in
version 1.20-2.

For the unstable distribution (sid) this problem has been fixed in
version 1.33-1.

We recommend that you upgrade your albatross package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      811 bdc42f9d146375eae49563994ffa00da
      Size/MD5 checksum:     9513 4e09703a232782c11e98fd5685a3b182
      Size/MD5 checksum:   256090 64c9e7357e51f85d228f17b2ea7ef9c9

  Architecture independent components:
      Size/MD5 checksum:    43444 0ccf06411a6e62cb82d3f3ff40eaee02
      Size/MD5 checksum:   500358 3ec346e1aba3a6d94db2ab653b61d397
      Size/MD5 checksum:    36530 f2cb88df2c0dfab3dc2b406cf502d021
      Size/MD5 checksum:    67432 8d16e01aea38756d0c3182b455b15d8c
      Size/MD5 checksum:    67440 f0dcff96941c1171d78bab7d172e74d7

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.2 (GNU/Linux)



- 漏洞信息

Albatross Template Manipulation Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Albatross contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the application not properly sanitizing user input supplied for execution in a template. This may allow an attacker to insert arbitrary Python code which will be executed by the vulnerable script.

- 时间线

2006-01-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.33 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. Debian GNU/Linux users should update their packages. Users of the stable distribution should install version 1.20-2. Users of the unstable distribution should install version 1.33-1.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Albatross Remote Arbitrary Code Execution Vulnerability
Design Error 16252
Yes No
2006-01-16 12:00:00 2007-02-20 08:28:00
The individual responsible for discovering this issue is not known.

- 受影响的程序版本

Albatross Albatross 1.33
Albatross Albatross 1.20
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1

- 漏洞讨论

Albatross is prone to an arbitrary code-execution vulnerability.

Reports indicate that malicious user-supplied data may be insecurely used as part of a template, which may lead to arbitrary code execution.

A remote attacker may exploit this issue to gain unauthorized access to an affected computer. Other attacks may be possible as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: <>.

- 解决方案

Debian has released advisory DSA 942-1 to address this issue. Please see the referenced advisory for more information.

Albatross 1.33 may not be vulnerable to this issue; Symantec could not confirm this.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

Albatross Albatross 1.20

- 相关参考