CVE-2006-0044
CVSS7.5
发布时间 :2006-01-17 20:51:00
修订时间 :2011-03-07 21:29:13
NMCOPS    

[原文]Unspecified vulnerability in context.py in Albatross web application toolkit before 1.33 allows remote attackers to execute arbitrary commands via unspecified vectors involving template files and the "handling of submitted form fields".


[CNNVD]Albatross未明漏洞(CNNVD-200601-171)

        Albatross Web应用程序工具箱1.33之前版本的context.py中存在未指定漏洞,远程攻击者可以通过与模板文件和"处理已提交的表单字段"有关的未明向量执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:albatross:albatross:1.32
cpe:/a:albatross:albatross:1.00
cpe:/a:albatross:albatross:1.01
cpe:/a:albatross:albatross:1.30
cpe:/a:albatross:albatross:1.20
cpe:/a:albatross:albatross:1.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0044
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0044
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-171
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2006/dsa-942
(VENDOR_ADVISORY)  DEBIAN  DSA-942
http://secunia.com/advisories/18457
(VENDOR_ADVISORY)  SECUNIA  18457
http://www.vupen.com/english/advisories/2006/0196
(UNKNOWN)  VUPEN  ADV-2006-0196
http://www.securityfocus.com/bid/16252
(UNKNOWN)  BID  16252
http://www.object-craft.com.au/projects/albatross/news.html
(UNKNOWN)  CONFIRM  http://www.object-craft.com.au/projects/albatross/news.html
http://security.debian.org/pool/updates/main/a/albatross/albatross_1.20-2.diff.gz
(UNKNOWN)  MISC  http://security.debian.org/pool/updates/main/a/albatross/albatross_1.20-2.diff.gz
http://xforce.iss.net/xforce/xfdb/24130
(UNKNOWN)  XF  albatross-context-command-execution(24130)
http://www.osvdb.org/22451
(UNKNOWN)  OSVDB  22451
http://secunia.com/advisories/18496
(UNKNOWN)  SECUNIA  18496

- 漏洞信息

Albatross未明漏洞
高危 设计错误
2006-01-17 00:00:00 2006-01-18 00:00:00
远程  
        Albatross Web应用程序工具箱1.33之前版本的context.py中存在未指定漏洞,远程攻击者可以通过与模板文件和"处理已提交的表单字段"有关的未明向量执行任意命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Albatross Albatross 1.20
        Debian python-albatross-common_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/a/albatross/python-albatr oss-common_1.20-2_all.deb
        Debian python-albatross-doc_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/a/albatross/python-albatr oss-doc_1.20-2_all.deb
        Debian python-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/a/albatross/python-albatr oss_1.20-2_all.deb
        Debian python2.2-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/a/albatross/python2.2-alb atross_1.20-2_all.deb
        Debian python2.3-albatross_1.20-2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/a/albatross/python2.3-alb atross_1.20-2_all.deb
        

- 漏洞信息 (F43249)

Debian Linux Security Advisory 942-1 (PacketStormID:F43249)
2006-01-21 00:00:00
Debian  debian.org
advisory,web,arbitrary,code execution
linux,debian
CVE-2006-0044
[点击下载]

Debian Security Advisory DSA 942-1 - A design error has been discovered in the Albatross web application toolkit that causes user supplied data to be used as part of template execution and hence arbitrary code execution.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 942-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 16th, 2006                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : albatross
Vulnerability  : design error
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2006-0044

A design error has been discovered in the Albatross web application
toolkit that causes user supplied data to be used as part of template
execution and hence arbitrary code execution.

The old stable distribution (woody) does not contain albatross packages.

For the stable distribution (sarge) this problem has been fixed in
version 1.20-2.

For the unstable distribution (sid) this problem has been fixed in
version 1.33-1.

We recommend that you upgrade your albatross package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/a/albatross/albatross_1.20-2.dsc
      Size/MD5 checksum:      811 bdc42f9d146375eae49563994ffa00da
    http://security.debian.org/pool/updates/main/a/albatross/albatross_1.20-2.diff.gz
      Size/MD5 checksum:     9513 4e09703a232782c11e98fd5685a3b182
    http://security.debian.org/pool/updates/main/a/albatross/albatross_1.20.orig.tar.gz
      Size/MD5 checksum:   256090 64c9e7357e51f85d228f17b2ea7ef9c9

  Architecture independent components:

    http://security.debian.org/pool/updates/main/a/albatross/python-albatross-common_1.20-2_all.deb
      Size/MD5 checksum:    43444 0ccf06411a6e62cb82d3f3ff40eaee02
    http://security.debian.org/pool/updates/main/a/albatross/python-albatross-doc_1.20-2_all.deb
      Size/MD5 checksum:   500358 3ec346e1aba3a6d94db2ab653b61d397
    http://security.debian.org/pool/updates/main/a/albatross/python-albatross_1.20-2_all.deb
      Size/MD5 checksum:    36530 f2cb88df2c0dfab3dc2b406cf502d021
    http://security.debian.org/pool/updates/main/a/albatross/python2.2-albatross_1.20-2_all.deb
      Size/MD5 checksum:    67432 8d16e01aea38756d0c3182b455b15d8c
    http://security.debian.org/pool/updates/main/a/albatross/python2.3-albatross_1.20-2_all.deb
      Size/MD5 checksum:    67440 f0dcff96941c1171d78bab7d172e74d7


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDy10dW5ql+IAeqTIRAmHsAJ94Pb9NP3y5LLggfzK9UV54ZVm9BACgsCNB
cOM5S4gifMlPLdWNjsVQThU=
=KxE8
-----END PGP SIGNATURE-----

    

- 漏洞信息

22451
Albatross Template Manipulation Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Albatross contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the application not properly sanitizing user input supplied for execution in a template. This may allow an attacker to insert arbitrary Python code which will be executed by the vulnerable script.

- 时间线

2006-01-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.33 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. Debian GNU/Linux users should update their packages. Users of the stable distribution should install version 1.20-2. Users of the unstable distribution should install version 1.33-1.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Albatross Remote Arbitrary Code Execution Vulnerability
Design Error 16252
Yes No
2006-01-16 12:00:00 2007-02-20 08:28:00
The individual responsible for discovering this issue is not known.

- 受影响的程序版本

Albatross Albatross 1.33
Albatross Albatross 1.20
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1

- 漏洞讨论

Albatross is prone to an arbitrary code-execution vulnerability.

Reports indicate that malicious user-supplied data may be insecurely used as part of a template, which may lead to arbitrary code execution.

A remote attacker may exploit this issue to gain unauthorized access to an affected computer. Other attacks may be possible as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released advisory DSA 942-1 to address this issue. Please see the referenced advisory for more information.

Albatross 1.33 may not be vulnerable to this issue; Symantec could not confirm this.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.


Albatross Albatross 1.20

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站