发布时间 :2006-02-18 16:02:00
修订时间 :2016-05-25 13:25:17

[原文]Unspecified vulnerability in (1) apreq_parse_headers and (2) apreq_parse_urlencoded functions in Apache2::Request (Libapreq2) before 2.07 allows remote attackers to cause a denial of service (CPU consumption) via unknown attack vectors that result in quadratic computational complexity.

[CNNVD]Apache2::Request 未明漏洞(CNNVD-200602-279)

        Apache2::Request (Libapreq2) 2.07之前版本的(1) apreq_parse_headers和(2) apreq_parse_urlencoded功能中存在未明漏洞。远程攻击者可以借助导致二次计算复杂性的未知攻击向量造成拒绝服务(CPU占用率高)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  16710
(UNKNOWN)  XF  libapreq2-parsing-dos(24917)

- 漏洞信息

Apache2::Request 未明漏洞
中危 设计错误
2006-02-18 00:00:00 2006-03-17 00:00:00
        Apache2::Request (Libapreq2) 2.07之前版本的(1) apreq_parse_headers和(2) apreq_parse_urlencoded功能中存在未明漏洞。远程攻击者可以借助导致二次计算复杂性的未知攻击向量造成拒绝服务(CPU占用率高)。

- 公告与补丁

        Apache Software Foundation libapreq2 2.0.4
        Debian libapache2-request-perl_2.04-dev-1sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_alpha.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_amd64.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_arm.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_hppa.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_i386.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_ia64.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_m68k.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_mips.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_mipsel.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_powerpc.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_s390.deb
        Debian libapache2-request-perl_2.04-dev-1sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge1_sparc.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_alpha.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_alpha.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_amd64.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_amd64.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_arm.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_arm.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_hppa.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_hppa.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_i386.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_i386.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_ia64.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_ia64.deb
        Debian libapache2-request-perl_2.04-dev-1sarge2_m68k.deb
        Debian GNU/Linux 3.1 alias sarge ache2-request-perl_2.04-dev-1sarge2_m68k.deb
        Debian libapache2-request-perl_2

- 漏洞信息

Generic Apache Request Library (libapreq) apreq_parse_* Functions Remote DoS
Remote / Network Access Denial of Service
Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.07 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Libapreq2 Quadratic Behavior Denial of Service Vulnerability
Design Error 16710
Yes No
2006-02-17 12:00:00 2006-12-15 07:58:00
This issue was reported by the vendor.

- 受影响的程序版本

Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Apache Software Foundation libapreq2 2.0.6
Apache Software Foundation libapreq2 2.0.4
Apache Software Foundation libapreq2 2.0.7

- 不受影响的程序版本

Apache Software Foundation libapreq2 2.0.7

- 漏洞讨论

Libapreq2 is prone to a vulnerability that may allow attackers to trigger a denial-of-service condition.

Libapreq2 versions prior to 2.0.7 are vulnerable.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 解决方案

The vendor has released version 2.0.7. to address this issue. Please see the reference section for more information.

Apache Software Foundation libapreq2 2.0.4

Apache Software Foundation libapreq2 2.0.6

- 相关参考