CVE-2006-0019
CVSS7.5
发布时间 :2006-01-20 16:03:00
修订时间 :2011-03-07 21:29:10
NMCOS    

[原文]Heap-based buffer overflow in the encodeURI and decodeURI functions in the kjs JavaScript interpreter engine in KDE 3.2.0 through 3.5.0 allows remote attackers to execute arbitrary code via a crafted, UTF-8 encoded URI.


[CNNVD]KDE KJS Encodeuri/Decodeuri远程堆溢出漏洞(CNNVD-200601-260)

        KDE是一个为UNIX工作站设计的强大的开源图形桌面环境。
        Konqueror和其他KDE组件所使用的JavaScript解释器引擎KJS中存在堆溢出漏洞,远程攻击者可能利用此漏洞在用户机器上执行任意指令。如果解码了攻击精心构造的UTF-8编码的URI序列的话,就会触发这个漏洞,导致Web浏览器崩溃或执行任意指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:kde:kde:3.3.2
cpe:/o:kde:kde:3.2
cpe:/o:kde:kde:3.2.3
cpe:/o:kde:kde:3.2.x
cpe:/o:kde:kde:3.3.x
cpe:/o:kde:kde:3.2.2
cpe:/o:kde:kde:3.4.1
cpe:/o:kde:kde:3.4.0
cpe:/o:kde:kde:3.2.0_beta1
cpe:/o:kde:kde:3.4
cpe:/o:kde:kde:3.3.1
cpe:/o:kde:kde:3.2.1
cpe:/o:kde:kde:3.2.0
cpe:/o:kde:kde:3.3.0
cpe:/o:kde:kde:3.3
cpe:/o:kde:kde:3.5.0
cpe:/o:kde:kde:3.4.2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11858Heap-based buffer overflow in the encodeURI and decodeURI functions in the kjs JavaScript interpreter engine in KDE 3.2.0 through 3.5.0 allo...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0019
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0019
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-260
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/422464/100/0/threaded
(PATCH)  BUGTRAQ  20060119 [KDE Security Advisory] kjs encodeuri/decodeuri heap overflow
http://www.kde.org/info/security/advisory-20060119-1.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.kde.org/info/security/advisory-20060119-1.txt
http://secunia.com/advisories/18500
(VENDOR_ADVISORY)  SECUNIA  18500
ftp://ftp.kde.org/pub/kde/security_patches/post-3.4.3-kdelibs-kjs.diff
(PATCH)  CONFIRM  ftp://ftp.kde.org/pub/kde/security_patches/post-3.4.3-kdelibs-kjs.diff
http://www.vupen.com/english/advisories/2006/0265
(UNKNOWN)  VUPEN  ADV-2006-0265
http://www.ubuntu.com/usn/usn-245-1
(UNKNOWN)  UBUNTU  USN-245-1
http://www.securityfocus.com/archive/1/archive/1/422489/100/0/threaded
(UNKNOWN)  SUSE  SUSE-SA:2006:003
http://www.redhat.com/support/errata/RHSA-2006-0184.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2006:0184
http://www.gentoo.org/security/en/glsa/glsa-200601-11.xml
(UNKNOWN)  GENTOO  GLSA-200601-11
http://www.debian.org/security/2006/dsa-948
(VENDOR_ADVISORY)  DEBIAN  DSA-948
http://secunia.com/advisories/18570
(UNKNOWN)  SECUNIA  18570
http://secunia.com/advisories/18561
(VENDOR_ADVISORY)  SECUNIA  18561
http://secunia.com/advisories/18559
(UNKNOWN)  SECUNIA  18559
http://secunia.com/advisories/18552
(UNKNOWN)  SECUNIA  18552
http://secunia.com/advisories/18540
(VENDOR_ADVISORY)  SECUNIA  18540
http://xforce.iss.net/xforce/xfdb/24242
(UNKNOWN)  XF  kde-kjs-bo(24242)
http://www.securityfocus.com/bid/16325
(UNKNOWN)  BID  16325
http://www.securityfocus.com/archive/1/archive/1/427976/100/0/threaded
(UNKNOWN)  FEDORA  FLSA:178606
http://www.osvdb.org/22659
(UNKNOWN)  OSVDB  22659
http://www.mandriva.com/security/advisories?name=MDKSA-2006:019
(UNKNOWN)  MANDRIVA  MDKSA-2006:019
http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.361107
(UNKNOWN)  SLACKWARE  SSA:2006-045-05
http://securitytracker.com/id?1015512
(UNKNOWN)  SECTRACK  1015512
http://securityreason.com/securityalert/364
(UNKNOWN)  SREASON  364
http://secunia.com/advisories/18899
(UNKNOWN)  SECUNIA  18899
http://secunia.com/advisories/18583
(UNKNOWN)  SECUNIA  18583

- 漏洞信息

KDE KJS Encodeuri/Decodeuri远程堆溢出漏洞
高危 缓冲区溢出
2006-01-20 00:00:00 2006-01-30 00:00:00
远程  
        KDE是一个为UNIX工作站设计的强大的开源图形桌面环境。
        Konqueror和其他KDE组件所使用的JavaScript解释器引擎KJS中存在堆溢出漏洞,远程攻击者可能利用此漏洞在用户机器上执行任意指令。如果解码了攻击精心构造的UTF-8编码的URI序列的话,就会触发这个漏洞,导致Web浏览器崩溃或执行任意指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        KDE KDE 3.2
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE KDE 3.2.1
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE KDE 3.2.2
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE KDE 3.2.3
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        Slackware kdelibs-3.2.3-i486-3.tgz
        Slackware 10.0:
        ftp://ftp.slackware.com/pub/slackware/slackware-10.0/patches/packages/ kdelibs-3.2.3-i486-3.tgz
        KDE KDE 3.3
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE KDE 3.3.1
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE KDE 3.3.2
        Slackware kdelibs-3.3.2-i486-3.tgz
        Slackware 10.1:
        ftp://ftp.slackware.com/pub/slackware/slackware-10.1/patches/packages/ kdelibs-3.3.2-i486-3.tgz
        Slackware kdelibs-3.4.2-i486-2.tgz
        Slackware 10.2:
        ftp://ftp.slackware.com/pub/slackware/slackware-10.2/patches/packages/ kdelibs-3.4.2-i486-2.tgz
        KDE KDE 3.3.2
        KDE post-3.2.3-kdelibs-kjs.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.2.3-kdelibs-kjs.diff
        KDE kdelibs 3.4
        SuSE kdelibs3-3.4.0-20.10.i586.rpm
        SUSE LINUX 9.3:
        ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/i586/kdelibs3-3.4.0-20 .10.i586.rpm
        SuSE kdelibs3-3.4.0-20.10.x86_64.rpm
        SUSE LINUX 9.3:
        ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/x86_64/kdelibs3-3.4.0- 20.10.x86_64.rpm
        SuSE kdelibs3-32bit-9.3-7.4.x86_64.rpm
        SUSE LINUX 9.3:
        ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/x86_64/kdelibs3-32bit- 9.3-7.4.x86_64.rpm
        SuSE kdelibs3-devel-3.4.0-20.10.i586.rpm
        SUSE LINUX 9.3:
        ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/i586/kdelibs3-devel-3. 4.0-20.10.i586.rpm
        SuSE kdelibs3-devel-3.4.0-20.10.x86_64.rpm
        SUSE LINUX 9.3:
        ftp://ftp.suse.com/pub/suse/i386/update/9.3/rpm/x86_64/kdelibs3-devel- 3.4.0-20.10.x86_64.rpm
        Ubuntu kdelibs-bin_3.4.0-0ubuntu3.5_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs-bin_3.4. 0-0ubuntu3.5_amd64.deb
        Ubuntu kdelibs-bin_3.4.0-0ubuntu3.5_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs-bin_3.4. 0-0ubuntu3.5_i386.deb
        Ubuntu kdelibs-bin_3.4.0-0ubuntu3.5_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs-bin_3.4. 0-0ubuntu3.5_powerpc.deb
        Ubuntu kdelibs-data_3.4.0-0ubuntu3.5_all.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs-data_3.4 .0-0ubuntu3.5_all.deb
        Ubuntu kdelibs-data_3.4.3-0ubuntu2_all.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs-data_3.4 .3-0ubuntu2_all.deb
        Ubuntu kdelibs_3.4.0-0ubuntu3.5_all.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs_3.4.0-0u buntu3.5_all.deb
        Ubuntu kdelibs4-dev_3.4.0-0ubuntu3.5_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4-dev_3.4 .0-0ubuntu3.5_amd64.deb
        Ubuntu kdelibs4-dev_3.4.0-0ubuntu3.5_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4-dev_3.4 .0-0ubuntu3.5_i386.deb
        Ubuntu kdelibs4-dev_3.4.0-0ubuntu3.5_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4-dev_3.4 .0-0ubuntu3.5_powerpc.deb
        Ubuntu kdelibs4-doc_3.4.0-0ubuntu3.5_all.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4-doc_3.4 .0-0ubuntu3.5_all.deb
        Ubuntu kdelibs4_3.4.0-0ubuntu3.5_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4_3.4.0-0 ubuntu3.5_amd64.deb
        Ubuntu kdelibs4_3.4.0-0ubuntu3.5_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4_3.4.0-0 ubuntu3.5_i386.deb
        Ubuntu kdelibs4_3.4.0-0ubuntu3.5_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/k/kdelibs/kdelibs4_3.4.0-0 u

- 漏洞信息

22659
KDE kjs UTF-8 Encoded URI Processing Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in KDE. "kjs" fails to perform correct boundary checking when decoding UTF8-encoded javascript resulting in a heap overflow. With a specially crafted request, an attacker can execute arbitreaty code resulting in a loss of integrity.

- 时间线

2006-01-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to the latest version for your distribution, as numerous vendors have reportedly fixed this vulnerability. In addition, the KDE project has released a patch for some versions.

- 相关参考

- 漏洞作者

- 漏洞信息

KDE KJS Encodeuri / Decodeuri Remote Heap Overflow Vulnerability
Boundary Condition Error 16325
Yes No
2006-01-20 12:00:00 2007-01-02 08:11:00
Maksim Orlovich discovered this issue.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Slackware Linux 10.2
Slackware Linux 10.1
Slackware Linux 10.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Enterprise Server 9
RedHat Linux 9.0 i386
RedHat Linux 7.3 i386
RedHat Application Server ES 3
Red Hat Fedora Core4
Red Hat Fedora Core3
Red Hat Fedora Core2
Red Hat Fedora Core1
KDE kdelibs 3.4.3
+ Gentoo Linux
KDE kdelibs 3.4
+ Gentoo Linux
KDE KDE 3.5
KDE KDE 3.4.3
KDE KDE 3.4.2
KDE KDE 3.4.1
+ Red Hat Fedora Core4
KDE KDE 3.4
KDE KDE 3.3.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
+ Debian Linux 3.1
KDE KDE 3.3.2
KDE KDE 3.3.1
+ Red Hat Fedora Core3
KDE KDE 3.3
KDE KDE 3.2.3
KDE KDE 3.2.2
+ KDE KDE 3.2.2
+ Red Hat Fedora Core2
KDE KDE 3.2.1
KDE KDE 3.2

- 漏洞讨论

KDE KJS is prone to a remote heap-overflow vulnerability.

Specifically, the issue presents itself when the application decodes specially crafted UTF-8 encoded URI sequences.

A successful attack can result in a remote compromise in the context of the user running the vulnerable application.

KDE versions 3.2.0, up to and including KDE 3.5.0, are vulnerable to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Please see the referenced advisories for more information and fixes.


KDE KDE 3.2

KDE KDE 3.2.1

KDE KDE 3.2.2

KDE KDE 3.2.3

KDE KDE 3.3

KDE KDE 3.3.1

KDE KDE 3.3.2

KDE KDE 3.3.2

KDE kdelibs 3.4

KDE KDE 3.4

KDE KDE 3.4.1

KDE KDE 3.4.2

KDE kdelibs 3.4.3

KDE KDE 3.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站