CVE-2005-4878
CVSS4.3
发布时间 :2009-02-18 15:30:00
修订时间 :2012-07-03 00:00:00
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in (1) acid_qry_main.php in Analysis Console for Intrusion Databases (ACID) 0.9.6b20 and (2) base_qry_main.php in Basic Analysis and Security Engine (BASE) 1.2, and unspecified other console scripts in these products, allow remote attackers to inject arbitrary web script or HTML via the sig[1] parameter and possibly other parameters, a different vulnerability than CVE-2007-6156.


[CNNVD]BASE和ACID多个跨站脚本攻击漏洞(CNNVD-200902-382)

        Analysis Console for Intrusion Databases(ACID)是一个数据库入侵分析工具,主要针对入侵检测设备,防火墙及其他安全设备采集的数据进行行分析处理的工具。
        (1) Analysis Console for Intrusion Databases (ACID) 0.9.6b20版本的分析控制台中的acid_qry_main.php
        (2) Basic Analysis and Security Engine (BASE) 1.2 以及这些产品的未知的其他控制台脚本的base_qry_main.php中存在多个跨站脚本攻击漏洞。远程攻击者可以借助sig[1]参数和其他可能的参数,注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:secureideas:basic_analysis_and_security_engine:1.2secureideas BASE Basic Analysis and Security Engine 1.2
cpe:/a:acid:analysis_console_for_intrusion_databases:0.9.6b20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4878
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4878
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200902-382
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/48848
(UNKNOWN)  XF  base-acid-sig1-xss(48848)
http://www.osvdb.org/24306
(UNKNOWN)  OSVDB  24306
http://www.debian.org/security/2005/dsa-893
(UNKNOWN)  DEBIAN  DSA-893
http://secunia.com/advisories/17523
(VENDOR_ADVISORY)  SECUNIA  17523
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=336788
(UNKNOWN)  CONFIRM  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=336788

- 漏洞信息

BASE和ACID多个跨站脚本攻击漏洞
中危 跨站脚本
2009-02-18 00:00:00 2009-02-26 00:00:00
远程  
        Analysis Console for Intrusion Databases(ACID)是一个数据库入侵分析工具,主要针对入侵检测设备,防火墙及其他安全设备采集的数据进行行分析处理的工具。
        (1) Analysis Console for Intrusion Databases (ACID) 0.9.6b20版本的分析控制台中的acid_qry_main.php
        (2) Basic Analysis and Security Engine (BASE) 1.2 以及这些产品的未知的其他控制台脚本的base_qry_main.php中存在多个跨站脚本攻击漏洞。远程攻击者可以借助sig[1]参数和其他可能的参数,注入任意web脚本或HTML。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.andrew.cmu.edu/user/rdanyliw/snort/snortacid.html
        

- 漏洞信息

24306
Basic Analysis and Security Engine (BASE) base_qry_main.php sig[1] Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Basic Analysis and Security Engine (BASE) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sig[1]' variable upon submission to base_qry_main.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.1 (kris) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Basic Analysis and Security Engine Multiple Unspecified Cross Site Scripting Vulnerabilities
Input Validation Error 33985
Yes No
2005-11-14 12:00:00 2009-03-05 10:46:00
Debian

- 受影响的程序版本

Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
BASE Basic Analysis and Security Engine 1.2
ACID Acidlab 0.9.6
BASE Basic Analysis and Security Engine 1.2.1

- 不受影响的程序版本

BASE Basic Analysis and Security Engine 1.2.1

- 漏洞讨论

Basic Analysis and Security Engine (BASE) is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied input.

Attacker-supplied HTML and script code would execute in the context of the affected site, potentially allowing the attacker to steal cookie-based authentication credentials.

Versions prior to BASE 1.2.1 are vulnerable.

- 漏洞利用

An attacker can exploit these issues by enticing an unsuspecting victim to follow a malicious URI.

- 解决方案

The vendor has released updates. Please contact the vendor for details.


ACID Acidlab 0.9.6

BASE Basic Analysis and Security Engine 1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站