CVE-2005-4873
CVSS7.5
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:58:04
NMO    

[原文]Multiple stack-based buffer overflows in the phpcups PHP module for CUPS 1.1.23rc1 might allow context-dependent attackers to execute arbitrary code via vectors that result in long function parameters, as demonstrated by the cups_get_dest_options function in phpcups.c.


[CNNVD]CNNVD数据暂缺。


[机译]多个基于栈的缓冲区溢出可能允许在phpcups PHP模块,用于CUPS 1.1.23rc1依赖于上下文的攻击者执行任意代码,通过载体,在很长的函数参数的结果,具体表现为的cups_get_dest_options功能,phpcups.c。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4873
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4873
(官方数据源) NVD

- 其它链接及资源

http://www.cups.org/str.php?L1102
(UNKNOWN)  CONFIRM  http://www.cups.org/str.php?L1102
http://xforce.iss.net/xforce/xfdb/41497
(UNKNOWN)  XF  phpcups-function-bo(41497)

- 漏洞信息

43889
phpcups PHP module for CUPS Multiple Overflows
Context Dependent Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2005-03-04 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站