CVE-2005-4864
CVSS7.2
发布时间 :2005-12-31 00:00:00
修订时间 :2016-10-17 23:38:35
NMCO    

[原文]Stack-based buffer overflow in libdb2.so in IBM DB2 7.x and 8.1 allows local users to execute arbitrary code via a long DB2LPORT environment variable.


[CNNVD]IBM DB2 libdb2.so本地缓冲区溢出漏洞(CNNVD-200512-797)

        IBM DB2是一个大型的商业关系数据库系统,面向电子商务、商业资讯、内容管理、客户关系管理等应用,可运行于AIX、HP-UX、Linux、Solaris、Windows等系统。
        IBM DB2提供的ibdb2.so.1库存在缓冲区溢出问题,本地攻击者可以利用这个漏洞以root用户权限在系统上执行任意指令。
        此漏洞可分为两个问题,第一当libdb2.so被装载时它读取DBLPORT环境变量,然后拷贝值到.bss段的缓冲区中,缓冲区会溢出,通过提供一个超长的DB2LPORT环境变量会填充libdb2.so.1库的.bss段的db2MLNPort_name缓冲区,然后溢出到db2node_name buffer到instprof_path缓冲区,然后进入instance_path缓冲区,最后到install_path缓冲区。第二个问题是当sqloInstancePath()读取install_path时,可以覆盖sqloGetInstancePath()函数的本地堆栈缓冲区。
        精心构建提交数据可能获得root用户权限,如db2cacpy是setuid root属性安装,程序装载此库并调用sqloInstancePath()溢出缓冲区。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:ibm:db2_universal_database:7.1::hp-ux
cpe:/a:ibm:db2_universal_database:8.0::hp-ux
cpe:/a:ibm:db2_universal_database:7.2::hp-ux
cpe:/a:ibm:db2_universal_database:7.0::hp-ux
cpe:/a:ibm:db2_universal_database:7.2::linux
cpe:/a:ibm:db2_universal_database:8.1::linux
cpe:/a:ibm:db2_universal_database:7.1::linux
cpe:/a:ibm:db2_universal_database:8.0::linuxIBM DB2 Universal Database 8.0 linux
cpe:/a:ibm:db2_universal_database:7.0::solaris
cpe:/a:ibm:db2_universal_database:7.2::solaris
cpe:/a:ibm:db2_universal_database:8.1::solaris
cpe:/a:ibm:db2_universal_database:7.1::solaris
cpe:/a:ibm:db2_universal_database:8.0::solarisIBM DB2 Universal Database 8.0 solaris
cpe:/a:ibm:db2_universal_database:7.0::aix
cpe:/a:ibm:db2_universal_database:7.1::aix
cpe:/a:ibm:db2_universal_database:8.0::aixIBM DB2 Universal Database 8.0 aix
cpe:/a:ibm:db2_universal_database:8.1::hp_ux
cpe:/a:ibm:db2_universal_database:7.0::linux
cpe:/a:ibm:db2_universal_database:7.2::aix
cpe:/a:ibm:db2_universal_database:8.1::aix

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4864
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4864
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-797
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110495092105541&w=2
(UNKNOWN)  BUGTRAQ  20050105 IBM DB2 libdb2.so buffer overflow (#NISR05012005B)
http://www-1.ibm.com/support/docview.wss?uid=swg1IY62042
(PATCH)  AIXAPAR  IY62042
http://www.ngssoftware.com/advisories/db205012005B.txt
(UNKNOWN)  MISC  http://www.ngssoftware.com/advisories/db205012005B.txt
http://www.securityfocus.com/bid/11390
(PATCH)  BID  11390
http://xforce.iss.net/xforce/xfdb/17616
(UNKNOWN)  XF  db2-db2lport-bo(17616)

- 漏洞信息

IBM DB2 libdb2.so本地缓冲区溢出漏洞
高危 缓冲区溢出
2005-12-31 00:00:00 2007-10-09 00:00:00
本地  
        IBM DB2是一个大型的商业关系数据库系统,面向电子商务、商业资讯、内容管理、客户关系管理等应用,可运行于AIX、HP-UX、Linux、Solaris、Windows等系统。
        IBM DB2提供的ibdb2.so.1库存在缓冲区溢出问题,本地攻击者可以利用这个漏洞以root用户权限在系统上执行任意指令。
        此漏洞可分为两个问题,第一当libdb2.so被装载时它读取DBLPORT环境变量,然后拷贝值到.bss段的缓冲区中,缓冲区会溢出,通过提供一个超长的DB2LPORT环境变量会填充libdb2.so.1库的.bss段的db2MLNPort_name缓冲区,然后溢出到db2node_name buffer到instprof_path缓冲区,然后进入instance_path缓冲区,最后到install_path缓冲区。第二个问题是当sqloInstancePath()读取install_path时,可以覆盖sqloGetInstancePath()函数的本地堆栈缓冲区。
        精心构建提交数据可能获得root用户权限,如db2cacpy是setuid root属性安装,程序装载此库并调用sqloInstancePath()溢出缓冲区。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.ibm.com/software/data/db2/udb/support/downloadv8.html
        http://www.ibm.com/software/data/db2/udb/support/downloadv7.html

- 漏洞信息

10517
IBM DB2 DB2LPORT Variable Overflow
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

A remote overflow exists in IBM's DB2. DB2 fails to perform proper bounds checking in the DB2LPORT function resulting in a buffer overflow. With a specially crafted request, an attacker can cause execute arbitrary code resulting in a loss of confidentiality and/or integrity.

- 时间线

2004-10-06 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, IBM has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站