CVE-2005-4852
CVSS5.0
发布时间 :2005-12-31 00:00:00
修订时间 :2015-07-28 10:41:31
NMCO    

[原文]The siteaccess URIMatching implementation in eZ publish 3.5 through 3.8 before 20050812 converts all non-alphanumeric characters in a URI to '_' (underscore), which allows remote attackers to bypass access restrictions by inserting certain characters in a URI, as demonstrated by a request for /admin:de, which matches a rule allowing only /admin_de to access /admin.


[CNNVD]eZ publish siteaccess URIMatching 绕过访问限制漏洞(CNNVD-200512-648)

        eZ publish 3.5至3.8在20050812之前的版本中实施的siteaccess URIMatching将一个URL中的所有非字母数字字符转化成'_' (下划线),远程攻击者因此可以通在URI中插入某些字符,如/admin:de请求,匹配只许可/admin_de访问/admin的规则,绕过访问限制。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:ez:ez_publish:3.5.11
cpe:/a:ez:ez_publish:3.6.12
cpe:/a:ez:ez_publish:3.7.10eZ Publish 3.7.10
cpe:/a:ez:ez_publish:3.8.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4852
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4852
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-648
(官方数据源) CNNVD

- 其它链接及资源

http://ez.no/download/ez_publish/changelogs/ez_publish_3_8/changelog_3_6_x_3_7_x_to_3_8_0
(PATCH)  CONFIRM  http://ez.no/download/ez_publish/changelogs/ez_publish_3_8/changelog_3_6_x_3_7_x_to_3_8_0
http://issues.ez.no/7025
(UNKNOWN)  CONFIRM  http://issues.ez.no/7025

- 漏洞信息

eZ publish siteaccess URIMatching 绕过访问限制漏洞
中危 未知
2005-12-31 00:00:00 2007-07-25 00:00:00
远程  
        eZ publish 3.5至3.8在20050812之前的版本中实施的siteaccess URIMatching将一个URL中的所有非字母数字字符转化成'_' (下划线),远程攻击者因此可以通在URI中插入某些字符,如/admin:de请求,匹配只许可/admin_de访问/admin的规则,绕过访问限制。

- 公告与补丁

        

- 漏洞信息

45590
eZ publish siteaccess URIMatching Implementation Crafted Request Access Bypass
Vendor Verified

- 漏洞描述

- 时间线

2005-08-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.8.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站