CVE-2005-4836
CVSS7.8
发布时间 :2005-12-31 00:00:00
修订时间 :2012-02-09 00:00:00
NMCOS    

[原文]The HTTP/1.1 connector in Apache Tomcat 4.1.15 through 4.1.40 does not reject NULL bytes in a URL when allowLinking is configured, which allows remote attackers to read JSP source files and obtain sensitive information.


[CNNVD]Apache Tomcat 'allowLinking'接受URI空字节信息泄露漏洞(CNNVD-200512-735)

        Apache Tomcat 4.1.15及其后续版本中的HTTP/1.1 connector在配置了allowLinking时并未在URL中注入空字节,因此,远程攻击者可以读取JSP源文件并获取敏感信息。

- CVSS (基础分值)

CVSS分值: 7.8 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-200 [信息暴露]

- CPE (受影响的平台与产品)

cpe:/a:apache:tomcat:4.1.28:alpha
cpe:/a:apache:tomcat:4.1.34
cpe:/a:apache:tomcat:4.1.18
cpe:/a:apache:tomcat:4.1.29:alpha
cpe:/a:apache:tomcat:4.1.24Apache Software Foundation Tomcat 4.1.24
cpe:/a:apache:tomcat:4.1.30
cpe:/a:apache:tomcat:4.1.19
cpe:/a:apache:tomcat:4.1.16
cpe:/a:apache:tomcat:4.1.29Apache Software Foundation Tomcat 4.1.29
cpe:/a:apache:tomcat:4.1.39
cpe:/a:apache:tomcat:4.1.27
cpe:/a:apache:tomcat:4.1.31Apache Software Foundation Tomcat 4.1.31
cpe:/a:apache:tomcat:4.1.40
cpe:/a:apache:tomcat:4.1.37
cpe:/a:apache:tomcat:4.1.20
cpe:/a:apache:tomcat:4.1.33
cpe:/a:apache:tomcat:4.1.35
cpe:/a:apache:tomcat:4.1.15Apache Software Foundation Tomcat 4.1.15
cpe:/a:apache:tomcat:4.1.32
cpe:/a:apache:tomcat:4.1.23
cpe:/a:apache:tomcat:4.1.21
cpe:/a:apache:tomcat:4.1.26
cpe:/a:apache:tomcat:4.1.22
cpe:/a:apache:tomcat:4.1.17
cpe:/a:apache:tomcat:4.1.36Apache Software Foundation Tomcat 4.1.36
cpe:/a:apache:tomcat:4.1.25

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4836
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4836
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-735
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/28483
(UNKNOWN)  BID  28483
http://tomcat.apache.org/security-4.html
(UNKNOWN)  CONFIRM  http://tomcat.apache.org/security-4.html

- 漏洞信息

Apache Tomcat 'allowLinking'接受URI空字节信息泄露漏洞
高危 信息泄露
2005-12-31 00:00:00 2007-05-18 00:00:00
远程  
        Apache Tomcat 4.1.15及其后续版本中的HTTP/1.1 connector在配置了allowLinking时并未在URL中注入空字节,因此,远程攻击者可以读取JSP源文件并获取敏感信息。

- 公告与补丁

        

- 漏洞信息

34880
Apache Tomcat HTTP/1.1 Connector NULL Byte Request JSP Source Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Vendor Verified

- 漏洞描述

Apache Tomcat contains a flaw which may allow a remote attacker to gain access to privileged information. The issue is due to the HTTP/1.1 connector not rejecting NULL bytes in a URL when 'allowLinking' is configured. This may allow an attacker to use a crafted request to obtain JSP source files.

- 时间线

2005-01-01 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Tomcat 'allowLinking' Accepts NULL Byte in URI Information Disclosure Vulnerability
Design Error 28483
Yes No
2007-04-10 12:00:00 2008-03-27 09:49:00
Unknown

- 受影响的程序版本

Apache Software Foundation Tomcat 4.1.37
Apache Software Foundation Tomcat 4.1.36
Apache Software Foundation Tomcat 4.1.36
Apache Software Foundation Tomcat 4.1.34
Apache Software Foundation Tomcat 4.1.34
+ Gentoo Linux 1.4 _rc3
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2
Apache Software Foundation Tomcat 4.1.32
Apache Software Foundation Tomcat 4.1.31
Apache Software Foundation Tomcat 4.1.30
Apache Software Foundation Tomcat 4.1.29
Apache Software Foundation Tomcat 4.1.28
Apache Software Foundation Tomcat 4.1.24
+ Gentoo Linux 1.4 _rc3
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
+ Gentoo Linux 1.2

- 漏洞讨论

Apache Tomcat is prone to a remote information-disclosure vulnerability because the HTTP/1.0 connector fails to properly handle a NULL byte in URIs when 'allowLinking' is configured.

Remote attackers can exploit this issue to obtain potentially sensitive information.

Note that HTTP/1.0 connector is deprecated; this issue is not scheduled to be fixed.

The issue affects Tomcat 4.1.15 and later.

- 漏洞利用

Attackers may launch attacks through a browser.

- 解决方案

Currently we are not aware of any vendor-supplied patches. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站