CVE-2005-4799
CVSS5.1
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:57:51
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Yet Another PHP Image Gallery (YaPIG) 0.95b and earlier allow remote attackers to inject arbitrary web script or HTML via (1) the Homepage field (aka the Website field) in an "image-related comment" and (2) the img_size field in view.php. NOTE: due to lack of details from the researcher, it is not clear whether the comment vector overlaps CVE-2005-1886.


[CNNVD]Yapig View.PHP跨站脚本攻击漏洞(CNNVD-200512-789)

        Yet Another PHP Image Gallery (YaPIG) 0.95b及更早版本中存在多个跨站脚本攻击漏洞,远程攻击者可以通过(1)在"图片相关评论"中的主页字段(又称网站字段)和(2)在view.php中的img_size字段来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:yapig:yapig:0.95b
cpe:/a:yapig:yapig:0.94u
cpe:/a:yapig:yapig:0.93u
cpe:/a:yapig:yapig:0.95
cpe:/a:yapig:yapig:0.92b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4799
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4799
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-789
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/22752
(UNKNOWN)  XF  yapig-viewphp-xss(22752)
http://xforce.iss.net/xforce/xfdb/22750
(UNKNOWN)  XF  yapig-website-xss(22750)
http://www.securityfocus.com/bid/15095
(UNKNOWN)  BID  15095
http://www.securityfocus.com/bid/15092
(UNKNOWN)  BID  15092
http://www.seclab.tuwien.ac.at/advisories/TUVSA-0510-001.txt
(VENDOR_ADVISORY)  MISC  http://www.seclab.tuwien.ac.at/advisories/TUVSA-0510-001.txt
http://www.osvdb.org/19959
(UNKNOWN)  OSVDB  19959
http://www.osvdb.org/19958
(UNKNOWN)  OSVDB  19958
http://secunia.com/advisories/17041
(VENDOR_ADVISORY)  SECUNIA  17041
http://archives.neohapsis.com/archives/bugtraq/2005-10/0161.html
(VENDOR_ADVISORY)  BUGTRAQ  20051013 Yapig: XSS / Code Injection Vulnerability

- 漏洞信息

Yapig View.PHP跨站脚本攻击漏洞
中危 跨站脚本
2005-12-31 00:00:00 2006-05-18 00:00:00
远程  
        Yet Another PHP Image Gallery (YaPIG) 0.95b及更早版本中存在多个跨站脚本攻击漏洞,远程攻击者可以通过(1)在"图片相关评论"中的主页字段(又称网站字段)和(2)在view.php中的img_size字段来注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

19958
YaPiG Image-related Comment Homepage Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

YaPiG contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate JavaScript when adding an image-related comment to the 'homepage' form field. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-10-13 2005-09-28
2005-10-13 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站