CVE-2005-4713
CVSS5.0
发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:28:50
NMCO    

[原文]Unspecified vulnerability in the SQL logging facility in PAM-MySQL 0.6.x before 0.6.2 and 0.7.x before 0.7pre3 allows remote attackers to cause a denial of service (segmentation fault) via unspecified vectors, probably involving the pam_mysql_sql_log function when being used in vsftpd, which does not include the IP address argument to an sprintf call.


[CNNVD]PAM-MySQL执行代码和拒绝服务漏洞(CNNVD-200512-649)

        PAM-MySQL 0.6.x中低于0.6.2的版本以及0.7.x中低于0.7pre3的版本中的SQL记录功能存在未明漏洞,远程攻击者可以通过未明向量,可能在用于vsftpd中时含pam_mysql_sql_log函数,这种使用时sprint调用不含有IP地址参数,从而发起拒绝服务攻击(分段故障)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pam_mysql:pam_mysql:0.3
cpe:/a:pam_mysql:pam_mysql:0.2
cpe:/a:pam_mysql:pam_mysql:0.6
cpe:/a:pam_mysql:pam_mysql:0.4
cpe:/a:pam_mysql:pam_mysql:0.5
cpe:/a:pam_mysql:pam_mysql:0.1
cpe:/a:pam_mysql:pam_mysql:0.4.7
cpe:/a:pam_mysql:pam_mysql:0.7_pre2
cpe:/a:pam_mysql:pam_mysql:0.7_pre1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4713
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4713
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-649
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16564
(PATCH)  BID  16564
http://sourceforge.net/forum/forum.php?forum_id=499394
(PATCH)  CONFIRM  http://sourceforge.net/forum/forum.php?forum_id=499394
http://secunia.com/advisories/18598
(VENDOR_ADVISORY)  SECUNIA  18598
http://www.vupen.com/english/advisories/2006/0490
(UNKNOWN)  VUPEN  ADV-2006-0490
http://sourceforge.net/tracker/index.php?func=detail&aid=1256243&group_id=5741&atid=305741
(UNKNOWN)  MISC  http://sourceforge.net/tracker/index.php?func=detail&aid=1256243&group_id=5741&atid=305741
http://www.gentoo.org/security/en/glsa/glsa-200606-18.xml
(UNKNOWN)  GENTOO  GLSA-200606-18
http://secunia.com/advisories/20690
(UNKNOWN)  SECUNIA  20690

- 漏洞信息

PAM-MySQL执行代码和拒绝服务漏洞
中危 资料不足
2005-12-31 00:00:00 2006-02-13 00:00:00
远程※本地  
        PAM-MySQL 0.6.x中低于0.6.2的版本以及0.7.x中低于0.7pre3的版本中的SQL记录功能存在未明漏洞,远程攻击者可以通过未明向量,可能在用于vsftpd中时含pam_mysql_sql_log函数,这种使用时sprint调用不含有IP地址参数,从而发起拒绝服务攻击(分段故障)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.7pre3.tar.gz

- 漏洞信息

22994
PAM-MySQL SQL Logging Facility Segfault DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

PAM-MySAQL contains a flaw that may allow a remote denial of service. The issue is triggered when by an unspecified flaw resulting in a segmentation fault in the SQL logging facility occurs, and will result in loss of availability for the service.

- 时间线

2005-09-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.2, 0.7pre3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站