CVE-2005-4705
CVSS5.0
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:57:35
NMCO    

[原文]BEA WebLogic Server and WebLogic Express 8.1 through SP4, 7.0 through SP6, and 6.1 through SP7, when a Java client application creates an SSL connection to the server after it has already created an insecure connection, will use the insecure connection, which allows remote attackers to sniff the connection.


[CNNVD]BEA WebLogic Server和WebLogic Express 远程攻击漏洞(CNNVD-200512-895)

        BEA WebLogic Server和WebLogic Express 8.1至SP4版本、7.0至SP6版本和6.1至SP7版本,当一个Jave客户端应用程序创建了一个到服务器的不安全连接之后再次创建到服务器的SSL连接时,此系统将会使用不安全的连接,这使得远程攻击者可以窥探到此连接的信息。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:bea:weblogic_server:6.1:sp7BEA Systems WebLogic Server 6.1 SP7
cpe:/a:bea:weblogic_server:8.1:sp1:expressBEA Systems WebLogic Express 8.1 SP1
cpe:/a:bea:weblogic_server:6.1:sp1BEA Systems WebLogic Server 6.1 SP1
cpe:/a:bea:weblogic_server:7.0:sp2
cpe:/a:bea:weblogic_server:6.1:sp6BEA Systems WebLogic Server 6.1 SP6
cpe:/a:bea:weblogic_server:7.0:sp5:express
cpe:/a:bea:weblogic_server:6.1:sp1:expressBEA Systems WebLogic Express 6.1 SP1
cpe:/a:bea:weblogic_server:7.0:sp1:express
cpe:/a:bea:weblogic_server:8.1:sp4BEA Systems WebLogic Server 8.1 SP4
cpe:/a:bea:weblogic_server:8.1:sp1BEA Systems WebLogic Server 8.1 SP1
cpe:/a:bea:weblogic_server:6.1:sp2:expressBEA Systems WebLogic Express 6.1 SP2
cpe:/a:bea:weblogic_server:8.1:sp4:expressBEA Systems WebLogic Express 8.1 SP4
cpe:/a:bea:weblogic_server:8.1:sp3BEA Systems WebLogic Server 8.1 SP3
cpe:/a:bea:weblogic_server:6.1:sp3:expressBEA Systems WebLogic Express 6.1 SP3
cpe:/a:bea:weblogic_server:7.0:sp6:express
cpe:/a:bea:weblogic_server:7.0:sp3
cpe:/a:bea:weblogic_server:7.0:sp4:express
cpe:/a:bea:weblogic_server:7.0:sp5
cpe:/a:bea:weblogic_server:7.0:sp1
cpe:/a:bea:weblogic_server:6.1:sp2BEA Systems WebLogic Server 6.1 SP2
cpe:/a:bea:weblogic_server:8.1:sp2:expressBEA Systems WebLogic Express 8.1 SP2
cpe:/a:bea:weblogic_server:6.1:sp3BEA Systems WebLogic Server 6.1 SP3
cpe:/a:bea:weblogic_server:7.0:sp6
cpe:/a:bea:weblogic_server:8.1:sp3:expressBEA Systems WebLogic Express 8.1 SP3
cpe:/a:bea:weblogic_server:6.1:sp4:expressBEA Systems WebLogic Express 6.1 SP4
cpe:/a:bea:weblogic_server:6.1:sp5:expressBEA Systems WebLogic Express 6.1 SP5
cpe:/a:bea:weblogic_server:6.1:sp7:expressBEA Systems WebLogic Express 6.1 SP7
cpe:/a:bea:weblogic_server:7.0:sp4
cpe:/a:bea:weblogic_server:6.1:sp5BEA Systems WebLogic Server 6.1 SP5
cpe:/a:bea:weblogic_server:6.1:sp4BEA Systems WebLogic Server 6.1 SP4
cpe:/a:bea:weblogic_server:7.0:sp2:express
cpe:/a:bea:weblogic_server:7.0:sp3:express
cpe:/a:bea:weblogic_server:8.1:sp2BEA Systems WebLogic Server 8.1 SP2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4705
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4705
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-895
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/20095
(PATCH)  OSVDB  20095
http://dev2dev.bea.com/pub/advisory/141
(VENDOR_ADVISORY)  BEA  BEA05-86.00

- 漏洞信息

BEA WebLogic Server和WebLogic Express 远程攻击漏洞
中危 未知
2005-12-31 00:00:00 2006-02-03 00:00:00
远程  
        BEA WebLogic Server和WebLogic Express 8.1至SP4版本、7.0至SP6版本和6.1至SP7版本,当一个Jave客户端应用程序创建了一个到服务器的不安全连接之后再次创建到服务器的SSL连接时,此系统将会使用不安全的连接,这使得远程攻击者可以窥探到此连接的信息。

- 公告与补丁

        

- 漏洞信息

20095
BEA WebLogic Consecutive Non-SSL T3 Connection Encryption Failure
Remote / Network Access Cryptographic
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

BEA WebLogic contains a flaw that may lead to an unauthorized information disclosure.  The problem is that if a Java client application creates an insecure and a secure SSL connection to the same server, then the first non-SSL connection will be used which will disclose sensitive information resulting in a loss of confidentiality.

- 时间线

2005-10-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 8.1 Service Pack 5 or higher, as it has been reported to fix this vulnerability. In addition, BEA Systems has released a patch for version 7.0 Service Pack 6 and 6.1 Service Pack 7.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站