CVE-2005-4699
CVSS6.4
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:57:34
NMCO    

[原文]Argument injection vulnerability in TellMe 1.2 and earlier allows remote attackers to modify command line arguments for the Whois program and obtain sensitive information via "--" style options in the q_Host parameter.


[CNNVD]TellMe 参数注入漏洞(CNNVD-200512-842)

        TellMe 1.2及更早版本存在参数注入漏洞, 远程攻击者可以通过q_Host参数中的"--"样式选项来修改命令行用于Whois程序的参数并获取敏感信息。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4699
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4699
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-842
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/22522
(PATCH)  XF  tellme-index-command-option(22522)
http://www.osvdb.org/19871
(PATCH)  OSVDB  19871
http://secunia.com/advisories/17078
(VENDOR_ADVISORY)  SECUNIA  17078
http://kimihia.org.nz/projects/tellme/files/tellme-1.2-1.3.diff
(PATCH)  CONFIRM  http://kimihia.org.nz/projects/tellme/files/tellme-1.2-1.3.diff
http://exploitlabs.com/files/advisories/EXPL-A-2005-015-tellme.txt
(VENDOR_ADVISORY)  MISC  http://exploitlabs.com/files/advisories/EXPL-A-2005-015-tellme.txt
http://archives.neohapsis.com/archives/fulldisclosure/2005-10/0107.html
(VENDOR_ADVISORY)  FULLDISC  20051005 Tellme 1.2

- 漏洞信息

TellMe 参数注入漏洞
中危 未知
2005-12-31 00:00:00 2006-02-03 00:00:00
远程  
        TellMe 1.2及更早版本存在参数注入漏洞, 远程攻击者可以通过q_Host参数中的"--"样式选项来修改命令行用于Whois程序的参数并获取敏感信息。

- 公告与补丁

        

- 漏洞信息

19871
Tellme index.php q_Host Variable Arbitrary Command Option Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Tellme contains a flaw that allows a remote attacker to execute arbitrary commands. This flaw exists because the application does not validate the 'q_Host' variable upon submission to the 'index.php' script, which may allow a remote attacker to access and execute arbitrary 'whois' command options resulting in a loss of integrity.

- 时间线

2005-10-05 2005-09-29
2005-10-05 Unknow

- 解决方案

Upgrade to version 1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站