CVE-2005-4674
CVSS7.5
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:57:30
NMCO    

[原文]Multiple SQL injection vulnerabilities in list.php in Complete PHP Counter allow remote attackers to execute arbitrary SQL commands via the (1) c or (2) s parameter.


[CNNVD]Complete PHP Counter list.php远程SQL注入漏洞(CNNVD-200512-692)

        Complete PHP Counter是一个基于Web的用于统计页面浏览量的记录器程序。
        Complete PHP Counter对用户提交给的参数缺少正确充分的过滤,远程攻击者可以利用此漏洞非授权操作数据库。Complete PHP Counter的list.php脚本对用户提交c或s参数数据缺少充分过滤,远程攻击者可以通过在输入数据中插入特定的SQL命令来非授权获取对数据库的访问。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4674
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4674
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-692
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/22758
(UNKNOWN)  XF  complete-php-counter-list-sql-injection(22758)
http://www.securityfocus.com/bid/15111
(UNKNOWN)  BID  15111
http://www.osvdb.org/20085
(UNKNOWN)  OSVDB  20085
http://www.osvdb.org/20084
(UNKNOWN)  OSVDB  20084
http://securitytracker.com/id?1015054
(UNKNOWN)  SECTRACK  1015054

- 漏洞信息

Complete PHP Counter list.php远程SQL注入漏洞
高危 SQL注入
2005-12-31 00:00:00 2006-01-30 00:00:00
远程  
        Complete PHP Counter是一个基于Web的用于统计页面浏览量的记录器程序。
        Complete PHP Counter对用户提交给的参数缺少正确充分的过滤,远程攻击者可以利用此漏洞非授权操作数据库。Complete PHP Counter的list.php脚本对用户提交c或s参数数据缺少充分过滤,远程攻击者可以通过在输入数据中插入特定的SQL命令来非授权获取对数据库的访问。
        

- 公告与补丁

        

- 漏洞信息

20085
Complete PHP Counter list.php SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Complete PHP Counter contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the list.php script not properly sanitizing user-supplied input to the 'c' or 's' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-10-10 Unknow
2005-10-10 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站