CVE-2005-4665
CVSS4.3
发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:28:45
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in PunBB 1.2.6 and earlier allows remote attackers to inject arbitrary web script or HTML via Javascript contained in nested, malformed BBcode url tags.


[CNNVD]PunBB BBCode 跨站脚本攻击漏洞(CNNVD-200512-777)

        PunBB 1.2.6及更早版本中存在跨站脚本攻击漏洞,远程攻击者可以通过在嵌套的有缺陷的BBcode url标签内含的Javascript来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:punbb:punbb:1.0
cpe:/a:punbb:punbb:1.1.3
cpe:/a:punbb:punbb:1.1.4
cpe:/a:punbb:punbb:1.1.1
cpe:/a:punbb:punbb:1.0.1
cpe:/a:punbb:punbb:1.1.2
cpe:/a:punbb:punbb:1.2.3
cpe:/a:punbb:punbb:1.1.5
cpe:/a:punbb:punbb:1.0_beta2
cpe:/a:punbb:punbb:1.0_rc2
cpe:/a:punbb:punbb:1.0_rc1
cpe:/a:punbb:punbb:1.2.5
cpe:/a:punbb:punbb:1.2.6
cpe:/a:punbb:punbb:1.0_beta1
cpe:/a:punbb:punbb:1.2.2
cpe:/a:punbb:punbb:1.0_alpha
cpe:/a:punbb:punbb:1.2.1
cpe:/a:punbb:punbb:1.0_beta3
cpe:/a:punbb:punbb:1.2.4
cpe:/a:punbb:punbb:1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4665
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4665
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-777
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/14808
(PATCH)  BID  14808
http://www.vupen.com/english/advisories/2005/1708
(UNKNOWN)  VUPEN  ADV-2005-1708
http://www.securityfocus.com/archive/1/archive/1/422088/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060116 PunBB BBCode URL Tag Script Injection Vulnerability
http://www.securityfocus.com/archive/1/422267/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060117 Re: PunBB BBCode URL Tag Script Injection Vulnerability
http://punbb.org/changelogs/1.2.6_to_1.2.7.txt
(UNKNOWN)  CONFIRM  http://punbb.org/changelogs/1.2.6_to_1.2.7.txt
http://xforce.iss.net/xforce/xfdb/22234
(UNKNOWN)  XF  punbb-bbcode-url-xss(22234)
http://www.punbb.org/changelogs/1.2.6_to_1.2.7.txt
(UNKNOWN)  CONFIRM  http://punbb.org/changelogs/1.2.6_to_1.2.7.txt
http://www.osvdb.org/19382
(UNKNOWN)  OSVDB  19382
http://secunia.com/advisories/16775
(UNKNOWN)  SECUNIA  16775

- 漏洞信息

PunBB BBCode 跨站脚本攻击漏洞
中危 跨站脚本
2005-12-31 00:00:00 2006-01-19 00:00:00
远程  
        PunBB 1.2.6及更早版本中存在跨站脚本攻击漏洞,远程攻击者可以通过在嵌套的有缺陷的BBcode url标签内含的Javascript来注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        PunBB PunBB 1.2.6
        PunBB punbb-1.2.7.tar.gz
        http://www.punbb.org/download/punbb-1.2.7.tar.gz

- 漏洞信息

19382
PunBB URL BBCode Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

PunBB contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the BBCode 'url' tags. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-09-02 Unknow
Unknow 2005-09-02

- 解决方案

Upgrade to version 1.2.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站