CVE-2005-4649
CVSS4.3
发布时间 :2005-12-31 00:00:00
修订时间 :2008-09-05 16:57:26
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Advanced Guestbook 2.2 and 2.3.1 allow remote attackers to inject arbitrary web script or HTML via (1) the entry parameter in index.php and (2) the gb_id parameter in comment.php. NOTE: The index.php/entry vector might be resultant from CVE-2005-1548.


[CNNVD]Advanced Guestbook 多个跨站脚本攻击漏洞(CNNVD-200512-682)

        Advanced Guestbook 2.2及2.3.1中存在多个跨站脚本攻击漏洞,远程攻击者可以通过(1)在index.php中的entry参数和(2)在comment.php中的gb_id参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:advanced_guestbook:advanced_guestbook:2.2
cpe:/a:advanced_guestbook:advanced_guestbook:2.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4649
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4649
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-682
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/22188
(UNKNOWN)  OSVDB  22188
http://www.morx.org/guestbook.txt
(UNKNOWN)  MISC  http://www.morx.org/guestbook.txt
http://archives.neohapsis.com/archives/fulldisclosure/2005-12/1230.html
(UNKNOWN)  FULLDISC  20051225 Advanced Guestbook remote XSS exploit

- 漏洞信息

Advanced Guestbook 多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-31 00:00:00 2006-01-17 00:00:00
远程  
        Advanced Guestbook 2.2及2.3.1中存在多个跨站脚本攻击漏洞,远程攻击者可以通过(1)在index.php中的entry参数和(2)在comment.php中的gb_id参数来注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

22188
Advanced Guestbook comment.php gb_id Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Advanced Guestbook contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'gb_id' variable upon submission to the comment.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-25 Unknow
2005-12-25 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站