发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:28:43

[原文]Cross-site scripting (XSS) vulnerability in the HTML WikiProcessor in Edgewall Trac 0.9.2 allows remote attackers to inject arbitrary web script or HTML via javascript in the SRC attribute of an IMG tag.

[CNNVD]Edgewall Software Trac HTML WikiProcessor Wiki Content HTML注入漏洞(CNNVD-200512-687)

        Edgewall Trac 0.9.2中的HTML WikiProcessor存在跨站脚本攻击漏洞, 远程攻击者可以通过IMG标签SRC属性中的javascript注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  16198
(UNKNOWN)  VUPEN  ADV-2006-0226
(UNKNOWN)  XF  trac-html-xss(24183)

- 漏洞信息

Edgewall Software Trac HTML WikiProcessor Wiki Content HTML注入漏洞
中危 跨站脚本
2005-12-31 00:00:00 2006-01-13 00:00:00
        Edgewall Trac 0.9.2中的HTML WikiProcessor存在跨站脚本攻击漏洞, 远程攻击者可以通过IMG标签SRC属性中的javascript注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Trac HTML WikiProcessor XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-12-11 Unknow
2005-12-11 Unknow

- 解决方案

Upgrade to version 0.9.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Edgewall Software Trac HTML WikiProcessor Wiki Content HTML Injection Vulnerability
Input Validation Error 16198
Yes No
2006-01-10 12:00:00 2006-02-07 08:55:00 is credited with the discovery of this vulnerability.

- 受影响的程序版本

Edgewall Software Trac 0.9.2
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Wire One Tanberg 880 0.9.3

- 不受影响的程序版本

Wire One Tanberg 880 0.9.3

- 漏洞讨论

Trac is prone to an HTML-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released version 0.9.3 to address this issue.

Please see the referenced advisories for further information:

- Debian Linux has released security advisory DSA 951-1 to address this issue.
- Debian Linux has released updated security advisory DSA 951-2 addressing this issue.

Edgewall Software Trac 0.9.2

- 相关参考