CVE-2005-4603
CVSS4.3
发布时间 :2005-12-31 00:00:00
修订时间 :2011-03-07 21:28:38
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in printthread.php in MyBB 1.0.1 and earlier allows remote attackers to inject arbitrary web script or HTML via a thread message, which is not properly sanitized in the print view of the thread.


[CNNVD]MyBB打印线程脚本HTML注入漏洞(CNNVD-200512-887)

        MyBB 1.0.1及更早版本中的printthread.php存在跨站脚本攻击漏洞,远程攻击者可以通过线程消息来注入任意Web脚本或HTML,系统对线程打印视图中的这种消息没有进行正确的审查。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mybulletinboard:mybulletinboard:rc2
cpe:/a:mybulletinboard:mybulletinboard:rc1
cpe:/a:mybulletinboard:mybulletinboard:1.0_pr2
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc4
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc1
cpe:/a:mybulletinboard:mybulletinboard:rc4
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc2
cpe:/a:mybulletinboard:mybulletinboard:rc3
cpe:/a:mybulletinboard:mybulletinboard:1.0_rc4
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc4_security_patch
cpe:/a:mybulletinboard:mybulletinboard:1.00_rc3
cpe:/a:mybulletinboard:mybulletinboard:1.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4603
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4603
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-887
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0012
(UNKNOWN)  VUPEN  ADV-2006-0012
http://www.securityfocus.com/bid/16096
(UNKNOWN)  BID  16096
http://www.securityfocus.com/archive/1/archive/1/420569/100/0/threaded
(UNKNOWN)  BUGTRAQ  20051231 MyBB XSS cross-site scripting
http://www.osvdb.org/21601
(UNKNOWN)  OSVDB  21601
http://securityreason.com/securityalert/310
(UNKNOWN)  SREASON  310
http://secunia.com/advisories/18281
(UNKNOWN)  SECUNIA  18281

- 漏洞信息

MyBB打印线程脚本HTML注入漏洞
中危 跨站脚本
2005-12-31 00:00:00 2006-01-03 00:00:00
远程  
        MyBB 1.0.1及更早版本中的printthread.php存在跨站脚本攻击漏洞,远程攻击者可以通过线程消息来注入任意Web脚本或HTML,系统对线程打印视图中的这种消息没有进行正确的审查。

- 公告与补丁

        

- 漏洞信息

21601
MyBulletinBoard (MyBB) printthread.php Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

MyBulletinBoard (MyBB) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input upon submission to the printthread.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-09 2005-11-07
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站