CVE-2005-4573
CVSS7.5
发布时间 :2005-12-29 06:03:00
修订时间 :2012-10-22 00:00:00
NMCO    

[原文]PHP remote file include vulnerability in plog-admin-functions.php in Plogger Beta 2 allows remote attackers to execute arbitrary code via a URL in the config[basedir] parameter.


[CNNVD]Plogger远程文件包含漏洞(CNNVD-200512-613)

        Plogger Beta 2的plog-admin-functions.php存在PHP远程文件包含漏洞,远程攻击者可以通过在config[basedir]参数中的URL执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4573
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4573
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-613
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15992
(PATCH)  BID  15992
http://www.plogger.org/two-point-one/
(PATCH)  CONFIRM  http://www.plogger.org/two-point-one/
http://securitytracker.com/id?1015380
(PATCH)  SECTRACK  1015380
http://xforce.iss.net/xforce/xfdb/23861
(UNKNOWN)  XF  plogger-plogadminfunctions-file-include(23861)
http://www.osvdb.org/22395
(UNKNOWN)  OSVDB  22395
http://securityreason.com/securityalert/273
(UNKNOWN)  SREASON  273
http://masendav.com/~duke/PloggerChanges_files/FileComparisonReport1.html
(UNKNOWN)  CONFIRM  http://masendav.com/~duke/PloggerChanges_files/FileComparisonReport1.html
http://freeconnects.webcindario.com/index.php?option=com_content&task=view&id=41&Itemid=1
(UNKNOWN)  MISC  http://freeconnects.webcindario.com/index.php?option=com_content&task=view&id=41&Itemid=1

- 漏洞信息

Plogger远程文件包含漏洞
高危 代码注入
2005-12-29 00:00:00 2005-12-29 00:00:00
远程  
        Plogger Beta 2的plog-admin-functions.php存在PHP远程文件包含漏洞,远程攻击者可以通过在config[basedir]参数中的URL执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.plogger.org/download/

- 漏洞信息

22395
Plogger plog-admin-functions.php config[basedir] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Plogger contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the plog-admin-functions.php script not properly sanitizing user input supplied to the "config[basedir]" variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-01-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version beta 2.1 or higher, as it has been reported to fix this vulnerability. In addition, the vendor has released a patch for the vulnerable version.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站