CVE-2005-4556
CVSS7.5
发布时间 :2005-12-28 06:03:00
修订时间 :2016-10-17 23:38:23
NMCO    

[原文]PHP remote file include vulnerability in IceWarp Web Mail 5.5.1, as used by Merak Mail Server 8.3.0r and VisNetic Mail Server version 8.3.0 build 1, when register_globals is enabled, allows remote attackers to include arbitrary local and remote PHP files via a URL in the (1) lang_settings and (2) language parameters in (a) accounts/inc/include.php and (b) admin/inc/include.php.


[CNNVD]IceWarp Web Mail多个文件包含漏洞(CNNVD-200512-586)

        IceWarp Web Mail(冰星网上邮件系统)是支持中日文邮件的Web Mail服务器引擎。
        IceWarp Web Mail中存在多个输入验证漏洞,具体如下:
        1) webmail和webadmin服务运行启用了register_global的PHP。在直接访问脚本时没有正确的初始化/accounts/inc/include.php和/admin/inc/include.php中的language和lang_settings变量,这可能允许覆盖变量,导致脚本包含本地或远程来源的任意PHP脚本。
        2) 没有正确验证/dir/include.html中对lang参数的输入,导致可能包含本地资源的任意文件。
        3) 没有正确验证/mail/settings.html中对language参数的输入,如果同覆盖lang_settings变量结合使用的话,就可能包含本地或远程资源的任意PHP脚本。
        4) 如果/mail/include.html遇到了无法识别的HTTP_USER_AGENT字符串的话,就可能无法正确的初始化default_layout和layout_settings变量。同覆盖default_layout和layout_settings变量结合使用的话就可能导致泄漏本地文件内容。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:icewarp:web_mail:5.5.1
cpe:/a:merak:mail_server:8.3.0r
cpe:/a:deerfield:visnetic_mail_server:8.3.0_build1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4556
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4556
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-586
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=full-disclosure&m=113570229524828&w=2
(UNKNOWN)  FULLDISC  20051227 Secunia Research: IceWarp Web Mail Multiple File
http://securitytracker.com/id?1015412
(UNKNOWN)  SECTRACK  1015412
http://www.securityfocus.com/archive/1/archive/1/420255/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051227 Secunia Research: IceWarp Web Mail Multiple File InclusionVulnerabilities
http://www.securityfocus.com/bid/16069
(UNKNOWN)  BID  16069

- 漏洞信息

IceWarp Web Mail多个文件包含漏洞
高危 输入验证
2005-12-28 00:00:00 2005-12-28 00:00:00
远程  
        IceWarp Web Mail(冰星网上邮件系统)是支持中日文邮件的Web Mail服务器引擎。
        IceWarp Web Mail中存在多个输入验证漏洞,具体如下:
        1) webmail和webadmin服务运行启用了register_global的PHP。在直接访问脚本时没有正确的初始化/accounts/inc/include.php和/admin/inc/include.php中的language和lang_settings变量,这可能允许覆盖变量,导致脚本包含本地或远程来源的任意PHP脚本。
        2) 没有正确验证/dir/include.html中对lang参数的输入,导致可能包含本地资源的任意文件。
        3) 没有正确验证/mail/settings.html中对language参数的输入,如果同覆盖lang_settings变量结合使用的话,就可能包含本地或远程资源的任意PHP脚本。
        4) 如果/mail/include.html遇到了无法识别的HTTP_USER_AGENT字符串的话,就可能无法正确的初始化default_layout和layout_settings变量。同覆盖default_layout和layout_settings变量结合使用的话就可能导致泄漏本地文件内容。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.deerfield.com
        http://www.merakmailserver.com/

- 漏洞信息

22077
IceWarp WebMail /accounts/inc/include.php Multiple Parameter Remote File Inclusion
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

VisNetic Mail Server Webmail contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to /accounts/inc/include.php not properly sanitizing user input supplied to multiple variables. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-12-27 Unknow
2005-12-27 Unknow

- 解决方案

Upgrade to version 8.3.5.r (Merak Mail Server), 8.3.5 (Visnetic WebMail), or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站