CVE-2005-4516
CVSS4.3
发布时间 :2005-12-27 20:03:00
修订时间 :2011-03-07 21:28:25
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in PHP-Fusion 6.00.200 through 6.00.300 allow remote attackers to inject arbitrary web script or HTML via (1) the sortby parameter in members.php and (2) IMG tags.


[CNNVD]PHP-Fusion Members.PHP跨站脚本攻击漏洞(CNNVD-200512-570)

        PHP-Fusion 6.00.200至6.00.300版本存在多个跨站脚本攻击漏洞,远程攻击者可通过(1)在中members.php的sortby参数和(2)IMG标签来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php_fusion:php_fusion:6.00.207
cpe:/a:php_fusion:php_fusion:6.00.300
cpe:/a:php_fusion:php_fusion:6.00.206
cpe:/a:php_fusion:php_fusion:6.00.204
cpe:/a:php_fusion:php_fusion:6.00.200
cpe:/a:php_fusion:php_fusion:6.00.205

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4516
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4516
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-570
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/18190/
(VENDOR_ADVISORY)  SECUNIA  18190
http://www.vupen.com/english/advisories/2005/3063
(UNKNOWN)  VUPEN  ADV-2005-3063
http://www.securityfocus.com/bid/15931
(UNKNOWN)  BID  15931
http://www.securityfocus.com/archive/1/archive/1/420109/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051222 XSS&Sql injection attack in PHP-Fusion 6.00.3 Released
http://www.osvdb.org/22050
(UNKNOWN)  OSVDB  22050
http://www.osvdb.org/22048
(UNKNOWN)  OSVDB  22048
http://securityreason.com/securityalert/272
(UNKNOWN)  SREASON  272

- 漏洞信息

PHP-Fusion Members.PHP跨站脚本攻击漏洞
中危 跨站脚本
2005-12-27 00:00:00 2005-12-28 00:00:00
远程  
        PHP-Fusion 6.00.200至6.00.300版本存在多个跨站脚本攻击漏洞,远程攻击者可通过(1)在中members.php的sortby参数和(2)IMG标签来注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

22048
PHP-Fusion members.php sortby Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Fusion contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'sortby' variable upon submission to the members.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-22 Unknow
2005-12-22 Unknow

- 解决方案

Upgrade to version 6.00.301 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站