CVE-2005-4504
CVSS7.8
发布时间 :2005-12-22 18:03:00
修订时间 :2011-03-07 21:28:24
NMCOP    

[原文]The khtml::RenderTableSection::ensureRows function in KHTMLParser in Apple Mac OS X 10.4.3 and earlier, as used by Safari and TextEdit, allows remote attackers to cause a denial of service (memory consumption and application crash) via HTML files with a large ROWSPAN attribute in a TD tag.


[CNNVD]Apple Mac OS X KHTML解析器远程拒绝服务漏洞(CNNVD-200512-545)

        Apple Mac OS X是苹果家族电脑所使用的操作系统。
        Mac OS X的KHTML解析器中存在拒绝服务漏洞。
        在运行特制的.html文件时,khtml::RenderTableSection::ensureRows没有正确的解析数据,导致崩溃。KTHML解析器试图将内部数组的大小调整为rowspan值所显示的单元数。如果这个值很大的话,就无法调整数组,应用程序就会终止。
        下面显示的是gdb中OS X 10.4.3上使用Safari所触发的崩溃:
        Program received signal SIGABRT, Aborted.
        0x9004716c in kill ()
        (gdb) bt
        #0 0x9004716c in kill ()
        #1 0x90128b98 in abort ()
        #2 0x95dcd974 in khtml::sYSMALLOc () <(=-- Is called because of sYSMALLOc(1234567890)
        #3 0x95dce1a4 in khtml::main_thread_realloc ()
        #4 0x95bc0d64 in KWQArrayImpl::resize ()
        #5 0x95c05428 in khtml::RenderTableSection::ensureRows ()
        #6 0x95c0784c in khtml::RenderTableSection::addCell ()
        #7 0x95c076ac in khtml::RenderTableRow::addChild ()
        #8 0x95bcb2d8 in DOM::NodeImpl::createRendererIfNeeded ()
        #9 0x95bcb1c4 in DOM::ElementImpl::attach ()
        #10 0x95bca254 in KHTMLParser::insertNode ()
        #11 0x95bcadd8 in KHTMLParser::insertNode ()
        #12 0x95bcadd8 in KHTMLParser::insertNode ()
        #13 0x95bc83fc in KHTMLParser::parseToken ()
        #14 0x95bc54a4 in khtml::HTMLTokenizer::processToken ()
        #15 0x95bc6e08 in khtml::HTMLTokenizer::parseTag ()
        #16 0x95bc4d24 in khtml::HTMLTokenizer::write ()
        #17 0x95bc038c in KHTMLPart::write ()
        #18 0x959b510c in -[WebDataSource(WebPrivate) _commitLoadWithData:] ()
        #19 0x9598165c in -[WebMainResourceClient addData:] ()
        #20 0x95981588 in -[WebBaseResourceHandleDelegate didReceiveData:lengthReceived:] ()
        #21 0x959db930 in -[WebMainResourceClient didReceiveData:lengthReceived:] ()
        #22 0x95981524 in -[WebBaseResourceHandleDelegate connection:didReceiveData:lengthReceived:] ()
        #23 0x92910a64 in -[NSURLConnection(NSURLConnectionInternal) _sendDidReceiveDataCallback] ()
        #24 0x9290ef04 in -[NSURLConnection(NSURLConnectionInternal) _sendCallbacks] ()
        #25 0x9290eca0 in _sendCallbacks ()
        #26 0x9075db20 in __CFRunLoopDoSources0 ()
        #27 0x9075cf98 in __CFRunLoopRun ()
        #28 0x9075ca18 in CFRunLoopRunSpecific ()
        #29 0x931861e0 in RunCurrentEventLoopInMode ()
        #30 0x931857ec in ReceiveNextEventCommon ()
        #31 0x931856e0 in BlockUntilNextEventMatchingListInMode ()
        #32 0x93683904 in _DPSNextEvent ()
        #33 0x936835c8 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
        #34 0x00007910 in ?? ()
        #35 0x9367fb0c in -[NSApplication run] ()
        #36 0x93770618 in NSApplicationMain ()
        #37 0x0000307c in ?? ()
        #38 0x00057758 in ?? ()

- CVSS (基础分值)

CVSS分值: 7.8 [严重(HIGH)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.1.5Apple Mac OS X 10.1.5
cpe:/o:apple:mac_os_x:10.3.9Apple Mac OS X 10.3.9
cpe:/o:apple:mac_os_x_server:10.2.1Apple Mac OS X Server 10.2.1
cpe:/o:apple:mac_os_x:10.2Apple Mac OS X 10.2
cpe:/o:apple:mac_os_x:10.1.4Apple Mac OS X 10.1.4
cpe:/o:apple:mac_os_x_server:10.0Apple Mac OS X Server 10.0
cpe:/a:apple:safari:1.2.1Apple Safari 1.2.1
cpe:/a:apple:safari:1.2.2Apple Safari 1.2.2
cpe:/o:apple:mac_os_x:10.2.5Apple Mac OS X 10.2.5
cpe:/o:apple:mac_os_x_server:10.2Apple Mac OS X Server 10.2
cpe:/o:apple:mac_os_x_server:10.2.4Apple Mac OS X Server 10.2.4
cpe:/o:apple:mac_os_x_server:10.4.3Apple Mac OS X Server 10.4.3
cpe:/o:apple:mac_os_x:10.0Apple Mac OS X 10.0
cpe:/a:apple:safari:1.0Apple Safari 1.0
cpe:/a:apple:safari:1.1Apple Safari 1.1
cpe:/o:apple:mac_os_x:10.4Apple Mac OS X 10.4
cpe:/o:apple:mac_os_x:10.0.3Apple Mac OS X 10.0.3
cpe:/o:apple:mac_os_x_server:10.4Apple Mac OS X Server 10.4
cpe:/o:apple:mac_os_x:10.1.3Apple Mac OS X 10.1.3
cpe:/o:apple:mac_os_x:10.3.6Apple Mac OS X 10.3.6
cpe:/o:apple:mac_os_x:10.2.1Apple Mac OS X 10.2.1
cpe:/a:apple:safari:1.2Apple Safari 1.2
cpe:/o:apple:mac_os_x:10.3.8Apple Mac OS X 10.3.8
cpe:/o:apple:mac_os_x:10.2.6Apple Mac OS X 10.2.6
cpe:/a:apple:safari:1.2.3Apple Safari 1.2.3
cpe:/o:apple:mac_os_x:10.3.7Apple Mac OS X 10.3.7
cpe:/o:apple:mac_os_x:10.3Apple Mac OS X 10.3
cpe:/o:apple:mac_os_x_server:10.2.2Apple Mac OS X Server 10.2.2
cpe:/o:apple:mac_os_x:10.3.1Apple Mac OS X 10.3.1
cpe:/o:apple:mac_os_x:10.4.2Apple Mac OS X 10.4.2
cpe:/a:apple:safari:2.0.1Apple Safari 2.0.1
cpe:/o:apple:mac_os_x_server:10.2.6Apple Mac OS X Server 10.2.6
cpe:/o:apple:mac_os_x:10.2.7Apple Mac OS X 10.2.7
cpe:/o:apple:mac_os_x_server:10.1Apple Mac OS X Server 10.1
cpe:/o:apple:mac_os_x:10.1Apple Mac OS X 10.1
cpe:/o:apple:mac_os_x_server:10.3.5Apple Mac OS X Server 10.3.5
cpe:/o:apple:mac_os_x:10.4.1Apple Mac OS X 10.4.1
cpe:/a:apple:textedit:1.4
cpe:/o:apple:mac_os_x:10.0.1Apple Mac OS X 10.0.1
cpe:/o:apple:mac_os_x_server:10.1.2Apple Mac OS X Server 10.1.2
cpe:/o:apple:mac_os_x_server:10.4.1Apple Mac OS X Server 10.4.1
cpe:/o:apple:mac_os_x:10.0.4Apple Mac OS X 10.0.4
cpe:/a:apple:safari:2.0.2Apple Safari 2.0.2
cpe:/o:apple:mac_os_x_server:10.2.7Apple Mac OS X Server 10.2.7
cpe:/o:apple:mac_os_x:10.2.2Apple Mac OS X 10.2.2
cpe:/a:apple:safari:1.3Apple Safari 1.3
cpe:/o:apple:mac_os_x:10.3.3Apple Mac OS X 10.3.3
cpe:/a:apple:safari:2.0Apple Safari 2.0
cpe:/o:apple:mac_os_x_server:10.4.2Apple Mac OS X Server 10.4.2
cpe:/o:apple:mac_os_x:10.2.4Apple Mac OS X 10.2.4
cpe:/o:apple:mac_os_x_server:10.3.3Apple Mac OS X Server 10.3.3
cpe:/o:apple:mac_os_x_server:10.3.4Apple Mac OS X Server 10.3.4
cpe:/o:apple:mac_os_x:10.2.3Apple Mac OS X 10.2.3
cpe:/o:apple:mac_os_x:10.3.2Apple Mac OS X 10.3.2
cpe:/o:apple:mac_os_x:10.2.8Apple Mac OS X 10.2.8
cpe:/o:apple:mac_os_x_server:10.2.8Apple Mac OS X Server 10.2.8
cpe:/o:apple:mac_os_x:10.1.1Apple Mac OS X 10.1.1
cpe:/o:apple:mac_os_x_server:10.3.1Apple Mac OS X Server 10.3.1
cpe:/o:apple:mac_os_x_server:10.2.5Apple Mac OS X Server 10.2.5
cpe:/o:apple:mac_os_x:10.3.4Apple Mac OS X 10.3.4
cpe:/o:apple:mac_os_x_server:10.3.2Apple Mac OS X Server 10.3.2
cpe:/o:apple:mac_os_x:10.0.2Apple Mac OS X 10.0.2
cpe:/o:apple:mac_os_x_server:10.3Apple Mac OS X Server 10.3
cpe:/o:apple:mac_os_x_server:10.1.3Apple Mac OS X Server 10.1.3
cpe:/o:apple:mac_os_x_server:10.3.8Apple Mac OS X Server 10.3.8
cpe:/o:apple:mac_os_x_server:10.2.3Apple Mac OS X Server 10.2.3
cpe:/o:apple:mac_os_x:10.3.5Apple Mac OS X 10.3.5
cpe:/o:apple:mac_os_x_server:10.3.7Apple Mac OS X Server 10.3.7
cpe:/o:apple:mac_os_x_server:10.1.1Apple Mac OS X Server 10.1.1
cpe:/o:apple:mac_os_x:10.4.3Apple Mac OS X 10.4.3
cpe:/o:apple:mac_os_x_server:10.1.5Apple Mac OS X Server 10.1.5
cpe:/o:apple:mac_os_x:10.1.2Apple Mac OS X 10.1.2
cpe:/o:apple:mac_os_x_server:10.3.6Apple Mac OS X Server 10.3.6
cpe:/o:apple:mac_os_x_server:10.1.4Apple Mac OS X Server 10.1.4
cpe:/o:apple:mac_os_x_server:10.3.9Apple Mac OS X Server 10.3.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4504
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4504
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-545
(官方数据源) CNNVD

- 其它链接及资源

http://www.us-cert.gov/cas/techalerts/TA06-062A.html
(UNKNOWN)  CERT  TA06-062A
http://www.kb.cert.org/vuls/id/351217
(UNKNOWN)  CERT-VN  VU#351217
http://www.vupen.com/english/advisories/2006/0791
(UNKNOWN)  VUPEN  ADV-2006-0791
http://www.vupen.com/english/advisories/2005/3058
(UNKNOWN)  VUPEN  ADV-2005-3058
http://www.securityfocus.com/bid/16045
(UNKNOWN)  BID  16045
http://security-protocols.com/advisory/sp-x22-advisory.txt
(VENDOR_ADVISORY)  MISC  http://security-protocols.com/advisory/sp-x22-advisory.txt
http://secunia.com/advisories/18220
(VENDOR_ADVISORY)  SECUNIA  18220
http://xforce.iss.net/xforce/xfdb/23819
(UNKNOWN)  XF  macos-khtmlparser-dos(23819)
http://www.securityfocus.com/bid/16907
(UNKNOWN)  BID  16907
http://secunia.com/advisories/19064
(UNKNOWN)  SECUNIA  19064
http://lists.apple.com/archives/security-announce/2006/Mar/msg00000.html
(UNKNOWN)  APPLE  APPLE-SA-2006-03-01
http://docs.info.apple.com/jarticle.html?artnum=303382-en
(UNKNOWN)  CONFIRM  http://docs.info.apple.com/jarticle.html?artnum=303382-en
http://docs.info.apple.com/article.html?artnum=303382
(UNKNOWN)  CONFIRM  http://docs.info.apple.com/article.html?artnum=303382

- 漏洞信息

Apple Mac OS X KHTML解析器远程拒绝服务漏洞
高危 资料不足
2005-12-22 00:00:00 2005-12-27 00:00:00
远程※本地  
        Apple Mac OS X是苹果家族电脑所使用的操作系统。
        Mac OS X的KHTML解析器中存在拒绝服务漏洞。
        在运行特制的.html文件时,khtml::RenderTableSection::ensureRows没有正确的解析数据,导致崩溃。KTHML解析器试图将内部数组的大小调整为rowspan值所显示的单元数。如果这个值很大的话,就无法调整数组,应用程序就会终止。
        下面显示的是gdb中OS X 10.4.3上使用Safari所触发的崩溃:
        Program received signal SIGABRT, Aborted.
        0x9004716c in kill ()
        (gdb) bt
        #0 0x9004716c in kill ()
        #1 0x90128b98 in abort ()
        #2 0x95dcd974 in khtml::sYSMALLOc () <(=-- Is called because of sYSMALLOc(1234567890)
        #3 0x95dce1a4 in khtml::main_thread_realloc ()
        #4 0x95bc0d64 in KWQArrayImpl::resize ()
        #5 0x95c05428 in khtml::RenderTableSection::ensureRows ()
        #6 0x95c0784c in khtml::RenderTableSection::addCell ()
        #7 0x95c076ac in khtml::RenderTableRow::addChild ()
        #8 0x95bcb2d8 in DOM::NodeImpl::createRendererIfNeeded ()
        #9 0x95bcb1c4 in DOM::ElementImpl::attach ()
        #10 0x95bca254 in KHTMLParser::insertNode ()
        #11 0x95bcadd8 in KHTMLParser::insertNode ()
        #12 0x95bcadd8 in KHTMLParser::insertNode ()
        #13 0x95bc83fc in KHTMLParser::parseToken ()
        #14 0x95bc54a4 in khtml::HTMLTokenizer::processToken ()
        #15 0x95bc6e08 in khtml::HTMLTokenizer::parseTag ()
        #16 0x95bc4d24 in khtml::HTMLTokenizer::write ()
        #17 0x95bc038c in KHTMLPart::write ()
        #18 0x959b510c in -[WebDataSource(WebPrivate) _commitLoadWithData:] ()
        #19 0x9598165c in -[WebMainResourceClient addData:] ()
        #20 0x95981588 in -[WebBaseResourceHandleDelegate didReceiveData:lengthReceived:] ()
        #21 0x959db930 in -[WebMainResourceClient didReceiveData:lengthReceived:] ()
        #22 0x95981524 in -[WebBaseResourceHandleDelegate connection:didReceiveData:lengthReceived:] ()
        #23 0x92910a64 in -[NSURLConnection(NSURLConnectionInternal) _sendDidReceiveDataCallback] ()
        #24 0x9290ef04 in -[NSURLConnection(NSURLConnectionInternal) _sendCallbacks] ()
        #25 0x9290eca0 in _sendCallbacks ()
        #26 0x9075db20 in __CFRunLoopDoSources0 ()
        #27 0x9075cf98 in __CFRunLoopRun ()
        #28 0x9075ca18 in CFRunLoopRunSpecific ()
        #29 0x931861e0 in RunCurrentEventLoopInMode ()
        #30 0x931857ec in ReceiveNextEventCommon ()
        #31 0x931856e0 in BlockUntilNextEventMatchingListInMode ()
        #32 0x93683904 in _DPSNextEvent ()
        #33 0x936835c8 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
        #34 0x00007910 in ?? ()
        #35 0x9367fb0c in -[NSApplication run] ()
        #36 0x93770618 in NSApplicationMain ()
        #37 0x0000307c in ?? ()
        #38 0x00057758 in ?? ()

- 公告与补丁

        

- 漏洞信息 (F44321)

Apple Security Advisory 2006-03-01 (PacketStormID:F44321)
2006-03-03 00:00:00
Apple  apple.com
advisory,perl,vulnerability
apple,osx
CVE-2005-3319,CVE-2005-3353,CVE-2005-3391,CVE-2005-3392,CVE-2006-0384,CVE-2006-0391,CVE-2005-2713,CVE-2005-2714,CVE-2006-0386,CVE-2006-0383,CVE-2005-3706,CVE-2006-0395,CVE-2005-4217,CVE-2005-3712,CVE-2005-4504,CVE-2006-0387,CVE-2006-0388,CVE-2006-0394
[点击下载]

APPLE-SA-2006-03-01 Security Update 2006-001 - A new update has been released for Mac OS X that addresses vulnerabilities in apache_mod_php, automount, COM, Directory Services, FileVault, IPSec, LibSystem, Mail, perl, rsync, Safari, LaunchServices, and Syndication.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

APPLE-SA-2006-03-01 Security Update 2006-001

Security Update 2006-001 is now available and addresses the following
issues:

apache_mod_php
CVE-ID:  CVE-2005-3319, CVE-2005-3353, CVE-2005-3391, CVE-2005-3392
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Multiple security issues in PHP 4.4
Description:  PHP 4.4.1 fixes several security issues in the Apache
module and scripting environment. Details of the fixes are
available via the PHP web site (www.php.net). PHP ships with Mac OS
X but is disabled by default.

automount
CVE-ID:  CVE-2006-0384
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Malicious network servers may cause a denial of service or
arbitrary code execution
Description:  File servers on the local network may be able to cause
Mac OS X systems to mount file systems with reserved names. This
could cause the systems to become unresponsive, or possibly allow
arbitrary code delivered from the file servers to run on the target
system.

BOM
CVE-ID:  CVE-2006-0391
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Directory traversal may occur while unpacking archives with
BOM
Description:  The BOM framework handles the unpacking of certain
types of archives. This framework is vulnerable to a directory
traversal attack that can allow archived files to be unpacked into
arbitrary locations that are writable by the current user. This
update addresses the issue by properly sanitizing those paths.
Credit to Stephane Kardas of CERTA for reporting this issue.

Directory Services
CVE-ID:  CVE-2005-2713, CVE-2005-2714
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Malicious local users may create and manipulate files as
root
Description:  The passwd program is vulnerable to temporary file
attacks. This could lead to privilege elevation. This update
addresses the issue by anticipating a hostile environment and by
creating temporary files securely. Credit to Ilja van Sprundel of
Suresec LTD, vade79, and iDefense (idefense.com) for reporting this
issue.

FileVault
CVE-ID:  CVE-2006-0386
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  FileVault may permit access to files during when it is
first enabled
Description:  User directories are mounted in an unsafe fashion when
a FileVault image is created. This update secures the method in
which a FileVault image is created.

IPSec
CVE-ID:  CVE-2006-0383
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Remote denial of service against VPN connections
Description:  Incorrect handling of error conditions for virtual
private networks based on IPSec may allow a remote attacker to
cause a service interruption. This update addresses the issues by
correctly handling the conditions that may cause crashes. Credit to
OUSPG from the University of Oulu, NISCC, and CERT-FI for
coordinating and reporting this issue.

LibSystem
CVE-ID:  CVE-2005-3706
Available for:  Mac OS X v10.4.5, Mac OS X Server v10.4.5
Impact:  Attackers may cause crashes or arbitrary code execution
depending upon the application
Description:  An attacker able to cause an application to make
requests for large amounts of memory may also be able to trigger a
heap buffer overflow. This could cause the targeted application to
crash or execute arbitrary code. This update addresses the issue by
correctly handling these memory requests. This issue does not
affect systems prior to Mac OS X v10.4. Credit to Neil Archibald of
Suresec LTD for reporting this issue.

Mail
CVE-ID:  CVE-2006-0395
Available for:  Mac OS X v10.4.5, Mac OS X Server v10.4.5
Impact:  Download Validation fails to warn about unsafe file types
Description:  In Mac OS X v10.4 Tiger, when an email attachment is
double-clicked in Mail, Download Validation is used to warn the
user if the file type is not "safe". Certain techniques can be used
to disguise the file's type so that Download Validation is
bypassed. This update addresses the issue by presenting Download
Validation with the entire file, providing more information for
Download Validation to detect unknown or unsafe file types in
attachments.

perl
CVE-ID:  CVE-2005-4217
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9
Impact:  Perl programs may fail to drop privileges
Description:  When a perl program running as root attempts to switch
to another user ID, the operation may fail without notification to
the program. This may cause a program to continue to run with root
privileges, assuming they have been dropped. This can cause
security issues in third-party tools. This update addresses the
issue by preventing such applications from continuing if the
operation fails. This issue does not affect Mac OS X v10.4 or later
systems. Credit to Jason Self for reporting this issue.

rsync
CVE-ID:  CVE-2005-3712
Available for:  Mac OS X v10.4.5, Mac OS X Server v10.4.5
Impact:  Authenticated users may cause an rsync server to crash or
execute arbitrary code
Description:  A heap-based buffer overflow may be triggered when the
rsync server is used with the flag that allows extended attributes
to be transferred. It may be possible for a malicious user with
access to an rsync server to cause denial of service or code
execution. This update addresses the problem by ensuring that the
destination buffer is large enough to hold the extended attributes.
This issue does not affect systems prior to Mac OS X v10.4. Credit
to Jan-Derk Bakker for reporting this issue.

Safari
CVE-ID:  CVE-2005-4504
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Viewing a maliciously-crafted web page may result in
arbitrary code execution
Description:  A heap-based buffer overflow in WebKit's handling of
certain HTML could allow a malicious web site to cause a crash or
execute arbitrary code as the user viewing the site. This update
addresses the issue by preventing the condition causing the
overflow. Credit to Suresec LTD for reporting this issue.

Safari
CVE-ID:  CVE-2006-0387
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Viewing a malicious web page may cause arbitrary code
execution
Description:  By preparing a web page including specially-crafted
JavaScript, an attacker may trigger a stack buffer overflow that
could lead to arbitrary code execution with the privileges of the
user. This update addresses the issue by performing additional
bounds checking.

Safari
CVE-ID:  CVE-2006-0388
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Remote web sites can redirect to local resources, allowing
JavaScript to execute in the local domain
Description:  Safari's security model prevents remote resources from
causing redirection to local resources. An issue involving HTTP
redirection can cause the browser to access a local file, bypassing
certain restrictions. This update addresses the issue by preventing
cross-domain HTTP redirects.

Safari, LaunchServices
CVE-ID:  CVE-2006-0394
Available for:  Mac OS X v10.3.9, Mac OS X Server v10.3.9, Mac OS X
v10.4.5, Mac OS X Server v10.4.5
Impact:  Viewing a malicious web site may result in arbitrary code
execution
Description:  It is possible to construct a file which appears to be
a safe file type, such as an image or movie, but is actually an
application. When the "Open `safe' files after downloading" option
is enabled in Safari's General preferences, visiting a malicious
web site may result in the automatic download and execution of such
a file. A proof-of-concept has been detected on public web sites
that demonstrates the automatic execution of shell scripts. This
update addresses the issue by performing additional download
validation so that the user is warned (in Mac OS X v10.4.5) or the
download is not automatically opened (in Mac OS X v10.3.9).

Syndication
CVE-ID:  CVE-2006-0389
Available for:  Mac OS X v10.4.5, Mac OS X Server v10.4.5
Impact:  Subscriptions to malicious RSS content can lead to
cross-site scripting
Description:  Syndication (Safari RSS) may allow JavaScript code
embedded in feeds to run within the context of the RSS reader
document, allowing malicious feeds to circumvent Safari's security
model. This update addresses the issue by properly removing
JavaScript code from feeds. Syndication is only available in Mac OS
X v10.4 and later.

The following security enhancements are also included in this update:

FileVault: AES-128 encrypted FileVault disk images are now created
with more restrictive operating system permissions. Credit to Eric
Hall of DarkArt Consulting Services for reporting this issue.

iChat: A malicious application named Leap.A that attempts to
propagate using iChat has been detected. With this update for Mac
OS X v10.4.5 and Mac OS X Server v10.4.5, iChat now uses Download
Validation to warn of unknown or unsafe file types during file
transfers.

Users should use caution when opening files that are obtained from
the network. Further information is available via:
http://docs.info.apple.com/article.html?artnum=108009

Security Update 2006-001 may be obtained from the Software Update
pane in System Preferences, or Apple's Software Downloads web site:
http://www.apple.com/support/downloads/

For Mac OS X v10.4.5 (PowerPC) and Mac OS X Server v10.4.5
The download file is named:  "SecUpd2006-001Ti.dmg"
Its SHA-1 digest is:  999b73a54951b4e0a7f873fecf75f92840e8b439

For Mac OS X v10.4.5 (Intel)
The download file is named:  "SecUpd2006-001Intel.dmg"
Its SHA-1 digest is:  473f94264876fa49fa15a8b6bb4bc30956502ad5

For Mac OS X v10.3.9
The download file is named:  "SecUpd2006-001Pan.dmg"
Its SHA-1 digest is:  b6a000d451a1b1696726ff60142fc3da08042433

For Mac OS X Server v10.3.9
The download file is named:  "SecUpdSrvr2006-001Pan.dmg"
Its SHA-1 digest is:  2299380d72a61eadcbd0a5c6f46c924600ff5a9c

Information will also be posted to the Apple Product Security
web site:
http://docs.info.apple.com/article.html?artnum=61798

This message is signed with Apple's Product Security PGP key,
and details are available at:
http://www.apple.com/support/security/pgp/

-----BEGIN PGP SIGNATURE-----
Version: PGP Desktop 9.0.5 (Build 5050)

iQEVAwUBRAYYVoHaV5ucd/HdAQJQWggApQmizj2t3+/87Fqun66/HCEkFt2YhUoe
cmel0/KwJhWrk+LV+CYvixbDvKuGIjP8CWB9/s78YN93pOI5WcfyTKd07rEQYkT4
i8KPrM9QjdvgIjKd6O/VAOkzBc3DqV7KNVR2Hewa3jOigTm7Yxil9o/nZt1TLxAI
9TN0uduc13WHC8WE2N41I8MQ+VdGTX3ANZkfgR90lua4A2E1ab9kCN2qbg+E7Cus
SkwsKp0qSH7bl8v0/R6c1hsYG0T1RwSWU6arAEliqzrrIbCm0Yxtgwp/CYFWC46j
TQNCcppNgcr/pVPojACy8WFtQ3wEb6rJ4ZjH1C5nOem2EoCBh10WFw==
=1Ww0
-----END PGP SIGNATURE-----
    

- 漏洞信息

22037
Apple Mac OS X KHTMLParser khtml::RenderTableSection::ensureRows Crafted HTML DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in Mac OS X. The KHTMLParser fails to validate .html files resulting in a buffer overflow. With a specially crafted file, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-12-21 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站