CVE-2005-4501
CVSS4.3
发布时间 :2005-12-22 16:03:00
修订时间 :2011-03-07 21:28:24
NMCOS    

[原文]MediaWiki before 1.5.4 uses a hard-coded "internal placeholder string", which allows remote attackers to bypass protection against cross-site scripting (XSS) attacks and execute Javascript using inline style attributes, which are processed by Internet Explorer.


[CNNVD]MediaWiki内联样式属性安全检查绕过漏洞(CNNVD-200512-516)

        MediaWiki的1.5.4之前版本使用一个硬编码"内部占位符字符串",远程攻击者因此可以通过跨站脚本(XSS)攻击绕过防护并执行使用了内联样式属性并由Internet Explorer处理的Javascript。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.3.14MediaWiki 1.3.14
cpe:/a:mediawiki:mediawiki:1.5_beta2
cpe:/a:mediawiki:mediawiki:1.4.6MediaWiki 1.4.6
cpe:/a:mediawiki:mediawiki:1.4_beta6
cpe:/a:mediawiki:mediawiki:1.2.2MediaWiki 1.2.2
cpe:/a:mediawiki:mediawiki:1.5_alpha1
cpe:/a:mediawiki:mediawiki:1.4.2MediaWiki 1.4.2
cpe:/a:mediawiki:mediawiki:1.3.11MediaWiki 1.3.11
cpe:/a:mediawiki:mediawiki:1.4_beta4
cpe:/a:mediawiki:mediawiki:1.3.10MediaWiki 1.3.10
cpe:/a:mediawiki:mediawiki:1.4.8MediaWiki 1.4.8
cpe:/a:mediawiki:mediawiki:1.4_beta3
cpe:/a:mediawiki:mediawiki:1.4.3MediaWiki 1.4.3
cpe:/a:mediawiki:mediawiki:1.2.4MediaWiki 1.2.4
cpe:/a:mediawiki:mediawiki:1.1.0MediaWiki 1.1.0
cpe:/a:mediawiki:mediawiki:1.4.9MediaWiki 1.4.9
cpe:/a:mediawiki:mediawiki:1.5_beta1
cpe:/a:mediawiki:mediawiki:1.5_alpha2
cpe:/a:mediawiki:mediawiki:1.3.3MediaWiki 1.3.3
cpe:/a:mediawiki:mediawiki:1.4_beta5
cpe:/a:mediawiki:mediawiki:1.4.10MediaWiki 1.4.10
cpe:/a:mediawiki:mediawiki:1.3.2MediaWiki 1.3.2
cpe:/a:mediawiki:mediawiki:1.2.5MediaWiki 1.2.5
cpe:/a:mediawiki:mediawiki:1.3.7MediaWiki 1.3.7
cpe:/a:mediawiki:mediawiki:1.3.15MediaWiki 1.3.15
cpe:/a:mediawiki:mediawiki:1.4.1MediaWiki 1.4.1
cpe:/a:mediawiki:mediawiki:1.3.0MediaWiki 1.3.0
cpe:/a:mediawiki:mediawiki:1.3.13MediaWiki 1.3.13
cpe:/a:mediawiki:mediawiki:1.3.8MediaWiki 1.3.8
cpe:/a:mediawiki:mediawiki:1.3.6MediaWiki 1.3.6
cpe:/a:mediawiki:mediawiki:1.2.6MediaWiki 1.2.6
cpe:/a:mediawiki:mediawiki:1.2.3MediaWiki 1.2.3
cpe:/a:mediawiki:mediawiki:1.4.7MediaWiki 1.4.7
cpe:/a:mediawiki:mediawiki:1.3.1MediaWiki 1.3.1
cpe:/a:mediawiki:mediawiki:1.3.5MediaWiki 1.3.5
cpe:/a:mediawiki:mediawiki:1.4_beta2
cpe:/a:mediawiki:mediawiki:1.3.9MediaWiki 1.3.9
cpe:/a:mediawiki:mediawiki:1.2.1MediaWiki 1.2.1
cpe:/a:mediawiki:mediawiki:1.4_beta1
cpe:/a:mediawiki:mediawiki:1.3MediaWiki 1.3
cpe:/a:mediawiki:mediawiki:1.3.4MediaWiki 1.3.4
cpe:/a:mediawiki:mediawiki:1.3.12MediaWiki 1.3.12
cpe:/a:mediawiki:mediawiki:1.4.5MediaWiki 1.4.5
cpe:/a:mediawiki:mediawiki:1.2.0MediaWiki 1.2.0
cpe:/a:mediawiki:mediawiki:1.5.3MediaWiki 1.5.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4501
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4501
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-516
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16032
(PATCH)  BID  16032
http://www.mediawiki.org/wiki/Download
(PATCH)  CONFIRM  http://www.mediawiki.org/wiki/Download
http://secunia.com/advisories/18219
(VENDOR_ADVISORY)  SECUNIA  18219
http://www.vupen.com/english/advisories/2005/3059
(UNKNOWN)  VUPEN  ADV-2005-3059
http://xforce.iss.net/xforce/xfdb/23882
(UNKNOWN)  XF  mediawiki-placeholder-bypass-security(23882)
http://secunia.com/advisories/18717
(UNKNOWN)  SECUNIA  18717
http://lists.suse.com/archive/suse-security-announce/2006-Feb/0001.html
(UNKNOWN)  SUSE  SUSE-SR:2006:003

- 漏洞信息

MediaWiki内联样式属性安全检查绕过漏洞
中危 跨站脚本
2005-12-22 00:00:00 2005-12-27 00:00:00
远程  
        MediaWiki的1.5.4之前版本使用一个硬编码"内部占位符字符串",远程攻击者因此可以通过跨站脚本(XSS)攻击绕过防护并执行使用了内联样式属性并由Internet Explorer处理的Javascript。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/wikipedia/mediawiki-1.5.4.tar.gz?download

- 漏洞信息

21960
MediaWiki Hardcoded Placeholder String Inline Style Attribute Security Bypass XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-12-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MediaWiki Inline Style Attribute Security Check Bypass Vulnerability
Design Error 16032
Yes No
2005-12-22 12:00:00 2006-12-20 10:38:00
Reported by the vendor.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
MediaWiki MediaWiki 1.5.3
MediaWiki MediaWiki 1.5.4

- 不受影响的程序版本

MediaWiki MediaWiki 1.5.4

- 漏洞讨论

MediaWiki is prone to a vulnerability that may allow attackers to execute script code in a user's browser.

Security checks related to inline style attributes can be bypassed, facilitating injection of script code to be executed in a user's browser.

MediaWiki 1.5.3 is known to be vulnerable to this issue; other versions may be affected as well.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released MediaWiki 1.5.4 to address this issue.

SUSE Linux has released security advisory SUSE-SR:2006:003 addressing this issue. Please see the referenced advisory for further information.


MediaWiki MediaWiki 1.5.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站