发布时间 :2005-12-22 06:03:00
修订时间 :2011-09-13 00:00:00

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Sitekit CMS 6.6 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) query string, (2) textonly, (3) locID, and (4) lang parameters to (a) Default.aspx, and the (6) ClickFrom parameter to (b) Request-call-back.html and (c) registration-form.html. NOTE: the vendor states "This issue was resolved by a minor update to Sitekit CMS v6.6, sanitising the html code and eradicating related security issues."

[CNNVD]Sitekit CMS多个跨站脚本攻击漏洞(CNNVD-200512-519)

        Sitekit CMS 6.6及更早版本中存在多个跨站脚本攻击漏洞 ,远程攻击者可通过到(a)Default.aspx的(1)查询字符串,(2)textonly, (3)locID和(4)lang参数以及到(b)Request-call-back.html和(c)registration-form.html的(6)ClickFrom参数,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  OSVDB  22073
(PATCH)  OSVDB  22072
(PATCH)  OSVDB  22071
(UNKNOWN)  BID  16016
(UNKNOWN)  VIM  20060317 vendor ack/fix: Sitekit CMS

- 漏洞信息

Sitekit CMS多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-22 00:00:00 2006-06-06 00:00:00
        Sitekit CMS 6.6及更早版本中存在多个跨站脚本攻击漏洞 ,远程攻击者可通过到(a)Default.aspx的(1)查询字符串,(2)textonly, (3)locID和(4)lang参数以及到(b)Request-call-back.html和(c)registration-form.html的(6)ClickFrom参数,注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Sitekit CMS Default.aspx Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Sitekit CMS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'textonly', 'locID' or 'lang' variables upon submission to the default.aspx script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-21 Unknow
2005-12-21 Unknow

- 解决方案

Upgrade to version 6.6.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者