发布时间 :2005-12-22 06:03:00
修订时间 :2008-09-20 00:43:18

[原文]** DISPUTED ** SQL injection vulnerability in Quantum Art QP7.Enterprise (formerly Q-Publishing) allows remote attackers to execute arbitrary SQL commands via the p_news_id parameter to (1) news_and_events_new.asp and (2) news.asp. NOTE: on 20060227, the vendor disputed the accuracy of this report, saying that the p_news_id, news_and_events_new.asp, and news.asp are not specifically part of their product, although they could be dynamically generated through use of the product. Some investigation by CVE suggests evidence that the news_and_events_new.asp page has at least a forced invalid SQL syntax error, but this could not be repeated for news.asp.

[CNNVD]Quantum Art QP7.Enterprise多个SQL注入漏洞(CNNVD-200512-537)

        ** 争议 ** Quantum Art QP7.Enterprise(之前的Q-Publishing)存在SQL注入漏洞,远程攻击者可以通过传到(1)news_and_events_new.asp和(2)news.asp的p_news_id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  16022

- 漏洞信息

Quantum Art QP7.Enterprise多个SQL注入漏洞
高危 SQL注入
2005-12-22 00:00:00 2006-06-06 00:00:00
        ** 争议 ** Quantum Art QP7.Enterprise(之前的Q-Publishing)存在SQL注入漏洞,远程攻击者可以通过传到(1)news_and_events_new.asp和(2)news.asp的p_news_id参数执行任意SQL命令。

- 公告与补丁


- 漏洞信息

QP7.Enterprise news_and_events_new.asp p_news_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

QP7.Enterprise contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'news_and_events_new.asp' script not properly sanitizing user-supplied input to the 'p_news_id' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-21 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者