CVE-2005-4478
CVSS7.5
发布时间 :2005-12-22 06:03:00
修订时间 :2011-09-08 00:00:00
NMCO    

[原文]Multiple SQL injection vulnerabilities in Papoo 2.1.2 and earlier allow remote attackers to execute arbitrary SQL commands via the (1) menuid parameter to (a) index.php and (b) guestbook.php, and the (2) forumid and (3) reporeid_print parameters to (c) print.php.


[CNNVD]Papoo多个SQL注入漏洞(CNNVD-200512-531)

        Papoo 2.1.2及更早版本存在多个SQL注入漏洞,远程攻击者可以通过到(a)index.php和(b)guestbook.php的(1)menuid参数以及到(c)print.php的(2) forumid和(3)reporeid_print参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4478
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4478
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-531
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/3046
(VENDOR_ADVISORY)  VUPEN  ADV-2005-3046
http://www.securityfocus.com/bid/16020
(UNKNOWN)  BID  16020
http://www.osvdb.org/displayvuln.php?osvdb_id=21871
(UNKNOWN)  OSVDB  21871
http://www.osvdb.org/displayvuln.php?osvdb_id=21870
(UNKNOWN)  OSVDB  21870
http://www.osvdb.org/21869
(UNKNOWN)  OSVDB  21869
http://secunia.com/advisories/18152
(VENDOR_ADVISORY)  SECUNIA  18152
http://pridels0.blogspot.com/2005/12/papoo-multiple-sql-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/papoo-multiple-sql-vuln.html

- 漏洞信息

Papoo多个SQL注入漏洞
高危 SQL注入
2005-12-22 00:00:00 2006-06-06 00:00:00
远程  
        Papoo 2.1.2及更早版本存在多个SQL注入漏洞,远程攻击者可以通过到(a)index.php和(b)guestbook.php的(1)menuid参数以及到(c)print.php的(2) forumid和(3)reporeid_print参数执行任意SQL命令。

- 公告与补丁

        

- 漏洞信息

21869
Papoo index.php menuid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Papoo contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'menuid' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-21 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站