CVE-2005-4469
CVSS7.5
发布时间 :2005-12-21 19:03:00
修订时间 :2017-07-19 21:29:16
NMCO    

[原文]Multiple direct static code injection vulnerabilities in PHPGedView 3.3.7 and earlier allow remote attackers to execute arbitrary PHP code via (1) the username field in login.php, or the (2) user_language, (3) user_email, and (4) user_gedcomid parameters in login_register.php, which is directly inserted into authenticate.php.


[CNNVD]PHPGedView多个远程脚本代码执行漏洞(CNNVD-200512-510)

        PHPGedView 3.3.7及更早版本存在多个直接静态代码注入漏洞,远程攻击者可以通过(1)login.php中的username字段或login_register.php中的(2)user_language,(3)user_email和(4)user_gedcomid参数,这些参数直接插入在authenticate.php中,来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpgedview:phpgedview:2.52.3
cpe:/a:phpgedview:phpgedview:2.65.1
cpe:/a:phpgedview:phpgedview:2.65_beta5
cpe:/a:phpgedview:phpgedview:2.65
cpe:/a:phpgedview:phpgedview:2.65.2
cpe:/a:phpgedview:phpgedview:2.61.1
cpe:/a:phpgedview:phpgedview:3.3.7
cpe:/a:phpgedview:phpgedview:2.60
cpe:/a:phpgedview:phpgedview:2.61

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4469
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4469
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-510
(官方数据源) CNNVD

- 其它链接及资源

http://cvs.sourceforge.net/viewcvs.py/phpgedview/phpGedView/login_register.php?r1=1.71.2.35&r2=1.71.2.36
(PATCH)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpgedview/phpGedView/login_register.php?r1=1.71.2.35&r2=1.71.2.36
http://cvs.sourceforge.net/viewcvs.py/phpgedview/phpGedView/login_register.php?r1=1.71.2.36&r2=1.71.2.37
(PATCH)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/phpgedview/phpGedView/login_register.php?r1=1.71.2.36&r2=1.71.2.37
http://rgod.altervista.org/phpgedview_337_xpl.html
(UNKNOWN)  MISC  http://rgod.altervista.org/phpgedview_337_xpl.html
http://securitytracker.com/id?1015395
(UNKNOWN)  SECTRACK  1015395
http://www.securityfocus.com/archive/1/archive/1/419906/100/0/threaded
(UNKNOWN)  BUGTRAQ  20051220 PHPGedView <= 3.3.7 remote code execution
http://www.securityfocus.com/bid/15983
(PATCH)  BID  15983
http://www.vupen.com/english/advisories/2005/3033
(UNKNOWN)  VUPEN  ADV-2005-3033
https://exchange.xforce.ibmcloud.com/vulnerabilities/23873
(UNKNOWN)  XF  phpgedview-multi-field-xss(23873)
https://sourceforge.net/tracker/index.php?func=detail&aid=1386434&group_id=55456&atid=477081
(UNKNOWN)  CONFIRM  https://sourceforge.net/tracker/index.php?func=detail&aid=1386434&group_id=55456&atid=477081

- 漏洞信息

PHPGedView多个远程脚本代码执行漏洞
高危 输入验证
2005-12-21 00:00:00 2005-12-28 00:00:00
远程  
        PHPGedView 3.3.7及更早版本存在多个直接静态代码注入漏洞,远程攻击者可以通过(1)login.php中的username字段或login_register.php中的(2)user_language,(3)user_email和(4)user_gedcomid参数,这些参数直接插入在authenticate.php中,来执行任意PHP代码。

- 公告与补丁

        

- 漏洞信息

22010
PhpGedView Registration Multiple Field Arbitrary PHP Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PhpGedView contains a flaw that may allow a remote attacker to execute arbitrary PHP code. The issue is due to the 'login_register.php' script not properly sanitizing user-supplied input to the 'user_language', 'user_email' and 'user_gedcomid' fields before being stored in the 'authenticate.php' script, which may allow a remote attacker to execute arbitrary PHP code resulting in a loss of integrity.

- 时间线

2005-12-20 Unknow
2005-12-20 Unknow

- 解决方案

Upgrade to version 3.3.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站