发布时间 :2005-12-21 15:03:00
修订时间 :2008-09-05 16:56:56

[原文]SQL injection vulnerability in index.php in Beehive Forum 0.6.2 and earlier allows remote attackers to execute arbitrary SQL commands via the user_sess parameter.

[CNNVD]Beehive Forum Index.PHP SQL注入漏洞(CNNVD-200512-492)

        Beehive Forum 0.6.2及更早版本中的index.php存在SQL注入漏洞,远程攻击者可以通过user_sess参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20051221 [KAPDA::#17] - beehiveforum Script Injection
(UNKNOWN)  BID  16521

- 漏洞信息

Beehive Forum Index.PHP SQL注入漏洞
高危 SQL注入
2005-12-21 00:00:00 2005-12-21 00:00:00
        Beehive Forum 0.6.2及更早版本中的index.php存在SQL注入漏洞,远程攻击者可以通过user_sess参数执行任意SQL命令。

- 公告与补丁


- 漏洞信息

Beehive Forum index.php user_sess Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Beehive Forum contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'user_sess' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Beehive Forum Index.PHP SQL Injection Vulnerability
Input Validation Error 16521
Yes No
2005-12-22 12:00:00 2006-08-24 07:24:00
trueend5 is credited with the discovery of this vulnerability.

- 受影响的程序版本

Beehive Forum Beehive Forum 0.6.2

- 漏洞讨论

Beehive Forum is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

Successful exploitation can allow an attacker to bypass authentication and gain administrative access to a site. Other attacks may also be possible.

Beehive Forum 0.6.2 is reported to be vulnerable.

- 漏洞利用

An exploit is not required.

The following proof of concept examples are available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考