CVE-2005-4442
CVSS7.2
发布时间 :2005-12-20 21:03:00
修订时间 :2008-09-05 16:56:53
NMCO    

[原文]Untrusted search path vulnerability in OpenLDAP before 2.2.28-r3 on Gentoo Linux allows local users in the portage group to gain privileges via a malicious shared object in the Portage temporary build directory, which is part of the RUNPATH.


[CNNVD]Gentoo Linux多个软件包不安全RUNPATH漏洞(CNNVD-200512-436)

        Gentoo Linux是一个基于源码包的Linux系统。
        Gentoo Linux中的一些软件包可能向在运行时搜索函数库的目录列表中引入不安全的路径。此外,依赖于MakeMaker Perl模块创建配置的软件包可能错误的将LD_RUN_PATH拷贝到DT_RPATH。如果本地攻击者是"portage"组成员的话,就可以在Portage临时代码目录中创建恶意的共享对象。在运行时独立的可执行程序可能会加载对象,导致权限提升。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openldap:openldap:2.1.26
cpe:/a:openldap:openldap:2.0.25
cpe:/a:openldap:openldap:2.0.24
cpe:/a:openldap:openldap:2.1.27
cpe:/a:openldap:openldap:2.2.23
cpe:/a:openldap:openldap:2.1.5
cpe:/a:openldap:openldap:2.1.24
cpe:/a:openldap:openldap:2.0.6
cpe:/a:openldap:openldap:2.1.10
cpe:/a:openldap:openldap:2.0.12
cpe:/a:openldap:openldap:2.0.19
cpe:/a:openldap:openldap:2.1.2
cpe:/a:openldap:openldap:2.2.7
cpe:/a:openldap:openldap:2.0.23
cpe:/a:openldap:openldap:2.0.16
cpe:/a:openldap:openldap:2.1.8
cpe:/a:openldap:openldap:2.0.8
cpe:/a:openldap:openldap:2.2.11
cpe:/a:openldap:openldap:2.1.25
cpe:/a:openldap:openldap:2.1.29
cpe:/a:openldap:openldap:2.0.5
cpe:/a:openldap:openldap:2.2.27
cpe:/a:openldap:openldap:2.2.22
cpe:/a:openldap:openldap:2.2.13
cpe:/a:openldap:openldap:2.2.4
cpe:/a:openldap:openldap:2.1.28
cpe:/a:openldap:openldap:2.2.25
cpe:/a:openldap:openldap:2.0.3
cpe:/a:openldap:openldap:2.0.15
cpe:/a:openldap:openldap:2.0.17
cpe:/a:openldap:openldap:2.2.19
cpe:/a:openldap:openldap:2.0.14
cpe:/a:openldap:openldap:2.1.12
cpe:/a:openldap:openldap:2.2.26
cpe:/a:openldap:openldap:2.2.12
cpe:/a:openldap:openldap:2.2.16
cpe:/a:openldap:openldap:2.2.15
cpe:/a:openldap:openldap:2.2.14
cpe:/a:openldap:openldap:2.1.18
cpe:/a:openldap:openldap:2.1.9
cpe:/a:openldap:openldap:2.0.22
cpe:/a:openldap:openldap:2.1.11
cpe:/a:openldap:openldap:2.0.26
cpe:/a:openldap:openldap:2.1.6
cpe:/a:openldap:openldap:2.0.21
cpe:/a:openldap:openldap:2.0.18
cpe:/a:openldap:openldap:2.0.7
cpe:/a:openldap:openldap:2.1.19
cpe:/a:openldap:openldap:2.0.13
cpe:/a:openldap:openldap:2.1.20
cpe:/a:openldap:openldap:2.0.11
cpe:/a:openldap:openldap:2.1.4
cpe:/a:openldap:openldap:2.1.21
cpe:/a:openldap:openldap:2.1.22
cpe:/a:openldap:openldap:2.1.30
cpe:/a:openldap:openldap:2.1.13
cpe:/a:openldap:openldap:2.0.4
cpe:/a:openldap:openldap:2.0.27
cpe:/a:openldap:openldap:2.2.9
cpe:/a:openldap:openldap:2.0.1
cpe:/a:openldap:openldap:2.2.20
cpe:/a:openldap:openldap:2.2.28_r2
cpe:/a:openldap:openldap:2.1.16
cpe:/a:openldap:openldap:2.1.7
cpe:/a:openldap:openldap:2.0.10
cpe:/a:openldap:openldap:2.0.20
cpe:/a:openldap:openldap:2.0.2
cpe:/a:openldap:openldap:2.2.5
cpe:/a:openldap:openldap:2.0.9
cpe:/a:openldap:openldap:2.1.17
cpe:/a:openldap:openldap:2.2.18
cpe:/a:openldap:openldap:2.2.17
cpe:/a:openldap:openldap:2.1.23
cpe:/a:openldap:openldap:2.2.6
cpe:/a:openldap:openldap:2.2.8
cpe:/a:openldap:openldap:2.2.24
cpe:/a:openldap:openldap:2.2.10
cpe:/a:openldap:openldap:2.2.21
cpe:/a:openldap:openldap:2.0.0
cpe:/a:openldap:openldap:2.1.15
cpe:/a:openldap:openldap:2.1.3
cpe:/a:openldap:openldap:2.1.14

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4442
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4442
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-436
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15120
(PATCH)  BID  15120
http://www.gentoo.org/security/en/glsa/glsa-200512-07.xml
(PATCH)  GENTOO  GLSA-200512-07
http://secunia.com/advisories/18040/
(VENDOR_ADVISORY)  SECUNIA  18040

- 漏洞信息

Gentoo Linux多个软件包不安全RUNPATH漏洞
高危 设计错误
2005-12-20 00:00:00 2006-01-10 00:00:00
本地  
        Gentoo Linux是一个基于源码包的Linux系统。
        Gentoo Linux中的一些软件包可能向在运行时搜索函数库的目录列表中引入不安全的路径。此外,依赖于MakeMaker Perl模块创建配置的软件包可能错误的将LD_RUN_PATH拷贝到DT_RPATH。如果本地攻击者是"portage"组成员的话,就可以在Portage临时代码目录中创建恶意的共享对象。在运行时独立的可执行程序可能会加载对象,导致权限提升。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://security.gentoo.org/glsa/glsa-200510-14.xml

- 漏洞信息

21976
OpenLDAP RUNPATH Variable Local Privilege Escalation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-12-15 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站