CVE-2005-4421
CVSS7.5
发布时间 :2005-12-20 06:03:00
修订时间 :2011-03-07 21:28:14
NMCO    

[原文]Dev-Editor 3.0 allows remote attackers to access any directory outside the web root whose name is a substring of the web root directory name.


[CNNVD]Dev-Editor虚拟目录安全绕过漏洞(CNNVD-200512-474)

        Dev-Editor 3.0使得远程攻击者可以访问web根目录之外且其名字是web根目录名的子字符串的任意目录。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dev-editor:dev-editor:2.1
cpe:/a:dev-editor:dev-editor:2.3
cpe:/a:dev-editor:dev-editor:2.3.1
cpe:/a:dev-editor:dev-editor:3.0
cpe:/a:dev-editor:dev-editor:2.0
cpe:/a:dev-editor:dev-editor:2.3.2
cpe:/a:dev-editor:dev-editor:2.1a
cpe:/a:dev-editor:dev-editor:2.2a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4421
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4421
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-474
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15393
(PATCH)  BID  15393
http://secunia.com/advisories/17537/
(VENDOR_ADVISORY)  SECUNIA  17537
http://xforce.iss.net/xforce/xfdb/23057
(UNKNOWN)  XF  dev-editor-root-bypass-security(23057)
http://www.vupen.com/english/advisories/2005/2389
(UNKNOWN)  VUPEN  ADV-2005-2389
http://devedit.sourceforge.net/changelog.shtml
(UNKNOWN)  CONFIRM  http://devedit.sourceforge.net/changelog.shtml

- 漏洞信息

Dev-Editor虚拟目录安全绕过漏洞
高危 设计错误
2005-12-20 00:00:00 2005-12-20 00:00:00
远程  
        Dev-Editor 3.0使得远程攻击者可以访问web根目录之外且其名字是web根目录名的子字符串的任意目录。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/devedit/devedit-3.0.1.tar.gz?download
        

- 漏洞信息

20767
Dev-Editor Virtual Root Directory File Restriction Bypass
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站