CVE-2005-4388
CVSS4.3
发布时间 :2005-12-19 21:03:00
修订时间 :2011-03-07 21:28:11
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in search.cfm in CONTENS 3.0 and earlier allows remote attackers to inject arbitrary web script or HTML via the near parameter.


[CNNVD]CONTENS Near Parameter跨站脚本攻击漏洞(CNNVD-200512-427)

        CONTENS 3.0以及更早版本中的search.cfm存在跨站脚本攻击漏洞,远程攻击者可通过near参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:contens:contens:3.0
cpe:/a:contens:contens:2.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4388
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4388
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-427
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2981
(UNKNOWN)  VUPEN  ADV-2005-2981
http://xforce.iss.net/xforce/xfdb/23820
(UNKNOWN)  XF  contens-search-xss(23820)
http://www.securityfocus.com/bid/15943
(UNKNOWN)  BID  15943
http://www.osvdb.org/21824
(UNKNOWN)  OSVDB  21824
http://secunia.com/advisories/18143
(UNKNOWN)  SECUNIA  18143
http://pridels0.blogspot.com/2005/12/contens-searchcfm-multiple-input.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/contens-searchcfm-multiple-input.html

- 漏洞信息

CONTENS Near Parameter跨站脚本攻击漏洞
中危 跨站脚本
2005-12-19 00:00:00 2005-12-21 00:00:00
远程  
        CONTENS 3.0以及更早版本中的search.cfm存在跨站脚本攻击漏洞,远程攻击者可通过near参数注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

21824
CONTENS search.cfm near Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

CONTENS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'near' variable upon submission to the 'search.cfm' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-17 Unknow
2005-12-17 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

CONTENS Near Parameter Cross-Site Scripting Vulnerability
Input Validation Error 15943
Yes No
2005-12-19 12:00:00 2008-03-28 03:59:00
Discovered by rakstija r0t3d3Vil.

- 受影响的程序版本

CONTENS CONTENS 3.0

- 漏洞讨论

CONTENS is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has relesaed an update. Please contact the vendor for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站