CVE-2005-4386
CVSS4.3
发布时间 :2005-12-19 21:03:00
修订时间 :2012-08-06 00:00:00
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Colony CMS 2.75 and earlier allows remote attackers to inject arbitrary web script or HTML via unspecified search parameters.


[CNNVD]Colony搜索模块多个跨站脚本攻击漏洞(CNNVD-200512-407)

        Colony CMS 2.75及更早版本存在跨站脚本攻击漏洞,远程攻击者可以通过未指定的搜索参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:colony:colony_enterprise_cms
cpe:/a:colony:colony_government_cms
cpe:/a:colony:colony_cms:2.75
cpe:/a:colony:colony_e-commerce_cms:-

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4386
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4386
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-407
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2978
(UNKNOWN)  VUPEN  ADV-2005-2978
http://www.securityfocus.com/bid/15941
(UNKNOWN)  BID  15941
http://www.osvdb.org/21853
(UNKNOWN)  OSVDB  21853
http://pridels0.blogspot.com/2005/12/colony-cms-xss-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/colony-cms-xss-vuln.html

- 漏洞信息

Colony搜索模块多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-19 00:00:00 2006-08-28 00:00:00
远程  
        Colony CMS 2.75及更早版本存在跨站脚本攻击漏洞,远程攻击者可以通过未指定的搜索参数注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

21853
Colony CMS Search Module XSS
Remote / Network Access Input Manipulation
Loss of Integrity Patch / RCS
Exploit Unknown

- 漏洞描述

Red Ant Development's Colony CMS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate variables upon submission to the search script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-17 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Red Ant Development has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站