CVE-2005-4379
CVSS4.3
发布时间 :2005-12-19 21:03:00
修订时间 :2011-03-07 21:28:10
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Bitweaver 1.1 and 1.1.1 beta allow remote attackers to inject arbitrary web script or HTML via the (1) sort_mode parameter to (a) fisheye/list_galleries.php, (b) messages/message_box.php, and (c) users/my.php; the (2) post_id parameter to (d) blogs/view_post.php; the (3) blog_id parameter to (e) blogs/view.php; and the (4) search field to (f) users/my_groups.php.


[CNNVD]Bitweaver 多个跨站脚本攻击漏洞(CNNVD-200512-424)

        Bitweaver 1.1和1.1.1 beta版本中存在多个跨站脚本攻击漏洞,远程攻击者可通过(1) (a) fisheye/list_galleries.php,(b) messages/message_box.php,和(c) users/my.php的sort_mode参数注入任意Web脚本或HTML; (2) (d) blogs/view_post.php的post_id参数; (3)(e) blogs/view.php的blog_id参数;和(4) (f) users/my_groups.php的search字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4379
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4379
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-424
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2975
(UNKNOWN)  VUPEN  ADV-2005-2975
http://www.osvdb.org/21928
(UNKNOWN)  OSVDB  21928
http://www.osvdb.org/21927
(UNKNOWN)  OSVDB  21927
http://www.osvdb.org/21926
(UNKNOWN)  OSVDB  21926
http://www.osvdb.org/21925
(UNKNOWN)  OSVDB  21925
http://www.osvdb.org/21924
(UNKNOWN)  OSVDB  21924
http://www.bitweaver.org/forums/viewtopic.php?t=1299
(UNKNOWN)  CONFIRM  http://www.bitweaver.org/forums/viewtopic.php?t=1299
http://xforce.iss.net/xforce/xfdb/23816
(UNKNOWN)  XF  bitweaver-mygroups-xss(23816)
http://pridels0.blogspot.com/2005/12/bitweaver-multiple-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/bitweaver-multiple-vuln.html

- 漏洞信息

Bitweaver 多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-19 00:00:00 2006-06-07 00:00:00
远程  
        Bitweaver 1.1和1.1.1 beta版本中存在多个跨站脚本攻击漏洞,远程攻击者可通过(1) (a) fisheye/list_galleries.php,(b) messages/message_box.php,和(c) users/my.php的sort_mode参数注入任意Web脚本或HTML; (2) (d) blogs/view_post.php的post_id参数; (3)(e) blogs/view.php的blog_id参数;和(4) (f) users/my_groups.php的search字段注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

22492
bitweaver my_groups.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

bitweaver contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the 'blog_id', 'post_id', and 'sort_mode' parameters upon submission to the 'my_groups.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-12-17 Unknow
2005-12-17 2005-12-20

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站