CVE-2005-4372
CVSS4.3
发布时间 :2005-12-19 21:03:00
修订时间 :2011-03-07 21:28:06
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in account.html in Adaptive Website Framework (AWF) 2.10 and earlier allows remote attackers to inject arbitrary web script or HTML via the page parameter.


[CNNVD]Adaptive Website Framework跨站脚本攻击漏洞(CNNVD-200512-428)

        Adaptive Website Framework (AWF) 2.10及其更早版本中的account.html存在跨站脚本攻击漏洞。远程攻击者可以借助page参数注入任意的Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:liquid_bytes_technologies:adaptive_website_framework:1.11
cpe:/a:liquid_bytes_technologies:adaptive_website_framework:2.10
cpe:/a:liquid_bytes_technologies:adaptive_website_framework:2.01
cpe:/a:liquid_bytes_technologies:adaptive_website_framework:2.00

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4372
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4372
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-428
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2973
(UNKNOWN)  VUPEN  ADV-2005-2973
http://www.securityfocus.com/bid/15937
(UNKNOWN)  BID  15937
http://www.osvdb.org/21914
(UNKNOWN)  OSVDB  21914
http://www.awf-cms.org/news.html
(UNKNOWN)  CONFIRM  http://www.awf-cms.org/news.html
http://pridels0.blogspot.com/2005/12/awf-adaptive-website-framework-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/awf-adaptive-website-framework-vuln.html

- 漏洞信息

Adaptive Website Framework跨站脚本攻击漏洞
中危 跨站脚本
2005-12-19 00:00:00 2005-12-20 00:00:00
远程  
        Adaptive Website Framework (AWF) 2.10及其更早版本中的account.html存在跨站脚本攻击漏洞。远程攻击者可以借助page参数注入任意的Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

21914
Adaptive Website Framework (AWF) Multiple Templates page Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

AWF-CMS contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "page" variable upon submission to multiple template scripts. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.10-beta3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站