CVE-2005-4315
CVSS7.5
发布时间 :2005-12-16 19:03:00
修订时间 :2011-03-07 00:00:00
NMCO    

[原文]SQL injection vulnerability in the search function in Plexum PLEXCART X3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors, possibly involving the (1) s_itemname and (2) s_orderby parameters to plexcart.pl.


[CNNVD]Plexum PlexCart X3 SQL注入漏洞(CNNVD-200512-333)

        Plexum PLEXCART X3的搜索功能存在SQL注入漏洞,远程攻击者可以通过未明向量(可能涉及plexcart.pl的(1) s_itemname和(2) s_orderby参数)执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4315
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4315
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-333
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2924
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2924
http://www.securityfocus.com/bid/15900
(UNKNOWN)  BID  15900
http://www.osvdb.org/21712
(UNKNOWN)  OSVDB  21712
http://secunia.com/advisories/18033
(VENDOR_ADVISORY)  SECUNIA  18033
http://pridels0.blogspot.com/2005/12/plexcart-x3-sql-inj-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/plexcart-x3-sql-inj-vuln.html

- 漏洞信息

Plexum PlexCart X3 SQL注入漏洞
高危 SQL注入
2005-12-16 00:00:00 2007-03-30 00:00:00
远程  
        Plexum PLEXCART X3的搜索功能存在SQL注入漏洞,远程攻击者可以通过未明向量(可能涉及plexcart.pl的(1) s_itemname和(2) s_orderby参数)执行任意SQL命令。

- 公告与补丁

        

- 漏洞信息

21712
PlexCart X3 Product Search Module SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

PlexCart X3 contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the plexcart.pl script not properly sanitizing user-supplied input to the 's_itemname' and 's_orderby' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-15 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站