发布时间 :2005-12-16 19:03:00
修订时间 :2011-03-07 21:27:59

[原文]SQL injection vulnerability in index.php in AlmondSoft Almond Personals 4.05 allows remote attackers to execute arbitrary SQL commands via the id parameter.

[CNNVD]AlmondSoft Almond分类SQL注入漏洞(CNNVD-200512-330)

        AlmondSoft Almond Personals 4.05的index.php中存在SQL注入漏洞,远程攻击者可以通过id参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  personals-index-sql-injection(50393)
(UNKNOWN)  VUPEN  ADV-2005-2943
(UNKNOWN)  BID  15899

- 漏洞信息

AlmondSoft Almond分类SQL注入漏洞
高危 SQL注入
2005-12-16 00:00:00 2009-05-13 00:00:00
        AlmondSoft Almond Personals 4.05的index.php中存在SQL注入漏洞,远程攻击者可以通过id参数执行任意SQL命令。

- 公告与补丁


- 漏洞信息

AlmondSoft Almond Classifieds SQL Injection Vulnerability
Input Validation Error 15899
Yes No
2005-12-15 12:00:00 2008-07-02 07:30:00
rakstija r0t3d3Vil is credited with the discovery of this issue.

- 受影响的程序版本

AlmondSoft.Com Almond Classifieds

- 漏洞讨论

AlmondSoft Almond Classifieds is prone to an SQL-injection vulnerability because the application fails to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database.

UPDATE (June 30, 2008): The vendor indicates that this issue is not exploitable as reported because the parameter is sanitized.

- 漏洞利用

No exploit is required.

- 解决方案

Currently we are not aware of any vendor-supplied patches. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考