发布时间 :2005-12-16 19:03:00
修订时间 :2017-07-19 21:29:13

[原文]Cross-site scripting (XSS) vulnerability in Edgewall Trac 0.9, 0.9.1, and 0.9.2 allows remote attackers to inject arbitrary web script or HTML via the URL, which is not properly sanitized before it is returned in an error page.

[CNNVD]Edgewall Software Trac跨站脚本漏洞(CNNVD-200512-320)

        Edgewall Trac 0.9、0.9.1和0.9.2中存在跨站脚本攻击漏洞,远程攻击者可以通过返回错误页面之前未正确净化的URL注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  16386
(UNKNOWN)  VUPEN  ADV-2005-2936
(UNKNOWN)  XF  trac-url-path-xss(23775)

- 漏洞信息

Edgewall Software Trac跨站脚本漏洞
中危 跨站脚本
2005-12-16 00:00:00 2006-09-20 00:00:00
        Edgewall Trac 0.9、0.9.1和0.9.2中存在跨站脚本攻击漏洞,远程攻击者可以通过返回错误页面之前未正确净化的URL注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Trac URL Path Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Trac contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the URL path upon submission to the error page. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-12-15 Unknow
2005-12-15 2006-01-08

- 解决方案

Upgrade to version 0.9.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Edgewall Software Trac Cross-Site Scripting Vulnerability
Input Validation Error 16386
Yes No
2005-12-16 12:00:00 2006-02-07 08:55:00
Discovered by Christophe Truc.

- 受影响的程序版本

Edgewall Software Trac 0.9.2
Edgewall Software Trac 0.9.1
Edgewall Software Trac 0.9
Wire One Tanberg 880 0.9.3

- 不受影响的程序版本

Wire One Tanberg 880 0.9.3

- 漏洞讨论

Trac is prone to a cross-site scripting vulnerability.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

Trac 0.9.2 and prior versions are vulnerable.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 解决方案

The vendor has released Trac 0.9.3 to address this issue.

Gentoo has released advisory GLSA 200601-12 to address this issue. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:

emerge --sync
emerge --ask --oneshot --verbose ">=www-apps/trac-0.9.3"

Edgewall Software Trac 0.9

Edgewall Software Trac 0.9.1

Edgewall Software Trac 0.9.2

- 相关参考