CVE-2005-4303
CVSS7.5
发布时间 :2005-12-16 19:03:00
修订时间 :2008-09-20 00:42:38
NMCO    

[原文]SQL injection vulnerability in index.php for ezDatabase 2.1.2 and earlier allows remote attackers to execute arbitrary SQL commands via the db_id parameter.


[CNNVD]EZDatabase多个输入验证漏洞(CNNVD-200512-337)

        EZDatabase是用PHP和MySQL编写的在线数据库程序。
        EZDatabase中存在多个输入验证错误,如下:
        1. 没有正确验证对"p"参数的输入,可能导致包含本地资源的任意文件;
        2. 没有正确验证对"db_id"参数的输入,可能导致通过注入任意SQL代码来操控SQL查询;
        3. 没有正确验证对"cat_id"参数的输入,可能导致泄漏完整的安装路径。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4303
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4303
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-337
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15908
(UNKNOWN)  BID  15908
http://www.osvdb.org/21797
(UNKNOWN)  OSVDB  21797
http://pridels0.blogspot.com/2005/12/ezdatabase-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/ezdatabase-vuln.html

- 漏洞信息

EZDatabase多个输入验证漏洞
高危 SQL注入
2005-12-16 00:00:00 2006-01-10 00:00:00
远程  
        EZDatabase是用PHP和MySQL编写的在线数据库程序。
        EZDatabase中存在多个输入验证错误,如下:
        1. 没有正确验证对"p"参数的输入,可能导致包含本地资源的任意文件;
        2. 没有正确验证对"db_id"参数的输入,可能导致通过注入任意SQL代码来操控SQL查询;
        3. 没有正确验证对"cat_id"参数的输入,可能导致泄漏完整的安装路径。
        

- 公告与补丁

        

- 漏洞信息

21797
ezDatabase index.php db_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

ezDatabase contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the index.php script not properly sanitizing user-supplied input to the 'db_id' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-14 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站