CVE-2005-4268
CVSS3.7
发布时间 :2005-12-15 13:11:00
修订时间 :2011-07-18 21:33:23
NMCOP    

[原文]Buffer overflow in cpio 2.6-8.FC4 on 64-bit platforms, when creating a cpio archive, allows local users to cause a denial of service (crash) and possibly execute arbitrary code via a file whose size is represented by more than 8 digits.


[CNNVD]CPIO文件大小堆栈缓冲区溢出漏洞(CNNVD-200512-307)

        创建cpio存档时,64位平台上的cpio 2.6-8.FC4中存在缓冲区溢出,本地用户可以通过其大小以超过8个数字代表的文件造成拒绝服务(崩溃)并可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 3.7 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:6860VMware ESX,Service Console update for cpio.
oval:org.mitre.oval:def:10450Buffer overflow in cpio 2.6-8.FC4 on 64-bit platforms, when creating a cpio archive, allows local users to cause a denial of service (crash)...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4268
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4268
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-307
(官方数据源) CNNVD

- 其它链接及资源

https://issues.rpath.com/browse/RPL-1338
(UNKNOWN)  CONFIRM  https://issues.rpath.com/browse/RPL-1338
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172669
(UNKNOWN)  CONFIRM  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172669
http://xforce.iss.net/xforce/xfdb/23855
(UNKNOWN)  XF  cpio-file-size-bo(23855)
http://www.ubuntulinux.org/support/documentation/usn/usn-234-1
(UNKNOWN)  UBUNTU  USN-234-1
http://www.securityfocus.com/bid/16057
(UNKNOWN)  BID  16057
http://www.redhat.com/support/errata/RHSA-2010-0145.html
(UNKNOWN)  REDHAT  RHSA-2010:0145
http://www.redhat.com/support/errata/RHSA-2007-0245.html
(UNKNOWN)  REDHAT  RHSA-2007:0245
http://www.osvdb.org/22194
(UNKNOWN)  OSVDB  22194
http://secunia.com/advisories/25161
(UNKNOWN)  SECUNIA  25161
http://secunia.com/advisories/25098
(UNKNOWN)  SECUNIA  25098
http://secunia.com/advisories/20117
(UNKNOWN)  SECUNIA  20117
http://secunia.com/advisories/18395
(UNKNOWN)  SECUNIA  18395
http://secunia.com/advisories/18280
(UNKNOWN)  SECUNIA  18280
http://secunia.com/advisories/18278
(UNKNOWN)  SECUNIA  18278
http://secunia.com/advisories/18251
(UNKNOWN)  SECUNIA  18251
http://lists.suse.com/archive/suse-security-announce/2006-May/0004.html
(UNKNOWN)  SUSE  SUSE-SR:2006:010
http://frontal1.mandriva.com/security/advisories?name=MDKSA-2005:237
(UNKNOWN)  MANDRIVA  MDKSA-2005:237
ftp://ftp.freebsd.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-06:03.cpio.asc
(UNKNOWN)  FREEBSD  FreeBSD-SA-06:03

- 漏洞信息

CPIO文件大小堆栈缓冲区溢出漏洞
低危 缓冲区溢出
2005-12-15 00:00:00 2007-10-03 00:00:00
本地  
        创建cpio存档时,64位平台上的cpio 2.6-8.FC4中存在缓冲区溢出,本地用户可以通过其大小以超过8个数字代表的文件造成拒绝服务(崩溃)并可能执行任意代码。

- 公告与补丁

        

- 漏洞信息 (F93384)

VMware Security Advisory 2010-0013 (PacketStormID:F93384)
2010-09-01 00:00:00
VMware  vmware.com
advisory,perl
CVE-2005-4268,CVE-2010-0624,CVE-2010-0624,CVE-2010-2063,CVE-2010-1321,CVE-2010-1168,CVE-2010-1447
[点击下载]

VMware Security Advisory - The service console package cpio is updated to version 2.5-6.RHEL3. The service console package tar is updated to version 1.13.25-16.RHEL3. The service console packages for samba are updated to version samba-3.0.9-1.3E.17vmw, samba-client-3.0.9-1.3E.17vmw and samba-common-3.0.9-1.3E.17vmw. The service console package krb5 is updated to version 1.2.7-72. The service console package perl is updated to version 5.8.0-101.EL3.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
                   VMware Security Advisory

Advisory ID:       VMSA-2010-0013
Synopsis:          VMware ESX third party updates for Service Console
Issue date:        2010-08-31
Updated on:        2010-08-31 (initial release of advisory)
CVE numbers:       CVE-2005-4268 CVE-2010-0624 CVE-2010-2063
                   CVE-2010-1321 CVE-2010-1168 CVE-2010-1447
- ------------------------------------------------------------------------

1. Summary

   ESX 3.5 Console OS (COS) updates for COS packages perl, krb5, samba,
   tar, and cpio.

2. Relevant releases

   VMware ESX 3.5 without patches ESX350-201008405-SG,
   ESX350-201008407-SG, ESX350-201008410-SG, ESX350-201008411-SG,
   ESX350-201008412-SG.

   Notes:
   Effective May 2010, VMware's patch and update release program during
   Extended Support will be continued with the condition that all
   subsequent patch and update releases will be based on the latest
   baseline release version as of May 2010 (i.e. ESX 3.0.3 Update 1,
   ESX 3.5 Update 5, and VirtualCenter 2.5 Update 6). Refer to section
   "End of Product Availability FAQs" at
   http://www.vmware.com/support/policies/lifecycle/vi/faq.html for
   details.

   Extended support for ESX 3.0.3 ends on 2011-12-10.  Users should plan
   to upgrade to at least ESX 3.5 and preferably to the newest release
   available.

3. Problem Description

 a. Service Console update for cpio

    The service console package cpio is updated to version 2.5-6.RHEL3.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the names CVE-2005-4268 and CVE-2010-0624 to the issues
    addressed in this update.

    Column 4 of the following table lists the action required to
    remediate the vulnerability in each release, if a solution is
    available.  

    VMware         Product   Running  Replace with/
    Product        Version   on       Apply Patch
    =============  ========  =======  =================
    VirtualCenter  any       Windows  not affected

    hosted *       any       any      not affected

    ESXi           any       ESXi     not affected

    ESX            4.1       ESX      affected, patch pending
    ESX            4.0       ESX      affected, patch pending
    ESX            3.5       ESX      ESX350-201008405-SG
    ESX            3.0.3     ESX      affected, patch pending

  * hosted products are VMware Workstation, Player, ACE, Server, Fusion.

 b. Service Console update for tar

    The service console package tar is updated to version
    1.13.25-16.RHEL3

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the name CVE-2010-0624 to the issue addressed in this
    update.

    Column 4 of the following table lists the action required to
    remediate the vulnerability in each release, if a solution is
    available.  

    VMware         Product   Running  Replace with/
    Product        Version   on       Apply Patch
    =============  ========  =======  =================
    VirtualCenter  any       Windows  not affected

    hosted *       any       any      not affected

    ESXi           any       ESXi     not affected

    ESX            4.1       ESX      affected, patch pending
    ESX            4.0       ESX      affected, patch pending
    ESX            3.5       ESX      ESX350-201008407-SG
    ESX            3.0.3     ESX      affected, patch pending

  * hosted products are VMware Workstation, Player, ACE, Server, Fusion.

 c. Service Console update for samba

    The service console packages for samba are updated to version
    samba-3.0.9-1.3E.17vmw, samba-client-3.0.9-1.3E.17vmw and
    samba-common-3.0.9-1.3E.17vmw.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the name CVE-2010-2063 to the issue addressed in this
    update.

    Note:
    The issue mentioned above is present in the Samba server (smbd) and
    is not present in the Samba client or Samba common packages.

    To determine if your system has Samba server installed do a
    'rpm -q samba`.

    The following lists when the Samba server is installed on the ESX
    service console:

    - ESX 4.0, ESX 4.1
      The Samba server is not present on ESX 4.0 and ESX 4.1.

    - ESX 3.5
      The Samba server is present if an earlier patch for Samba has been
      installed.

    - ESX 3.0.3
      The Samba server is present if ESX 3.0.3 was upgraded from an
      earlier version of ESX 3 and a Samba patch was installed on that
      version.

    The Samba server is not needed to operate the service console and
    can be be disabled without loss of functionality to the service
    console.

    Column 4 of the following table lists the action required to
    remediate the vulnerability in each release, if a solution is
    available.  

    VMware         Product   Running  Replace with/
    Product        Version   on       Apply Patch
    =============  ========  =======  =================
    VirtualCenter  any       Windows  not affected

    hosted *       any       any      not affected

    ESXi           any       ESXi     not affected

    ESX            4.1       ESX      not applicable
    ESX            4.0       ESX      not applicable
    ESX            3.5       ESX      ESX350-201008410-SG
    ESX            3.0.3     ESX      affected, patch pending

  * hosted products are VMware Workstation, Player, ACE, Server, Fusion.

 d. Service Console update for krb5

    The service console package krb5 is updated to version 1.2.7-72.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the name CVE-2010-1321 to the issue addressed in this
    update.

    Column 4 of the following table lists the action required to
    remediate the vulnerability in each release, if a solution is
    available.  

    VMware         Product   Running  Replace with/
    Product        Version   on       Apply Patch
    =============  ========  =======  =================
    VirtualCenter  any       Windows  not affected

    hosted *       any       any      not affected

    ESXi           any       ESXi     not affected

    ESX            4.1       ESX      affected, patch pending
    ESX            4.0       ESX      affected, patch pending
    ESX            3.5       ESX      ESX350-201008411-SG
    ESX            3.0.3     ESX      affected, patch pending

  * hosted products are VMware Workstation, Player, ACE, Server, Fusion.

 e. Service Console update for perl

    The service console package perl is updated to version
    5.8.0-101.EL3.

    The Common Vulnerabilities and Exposures project (cve.mitre.org)
    has assigned the names CVE-2010-1168 and CVE-2010-1447 to the issue
    addressed in this update.

    Column 4 of the following table lists the action required to
    remediate the vulnerability in each release, if a solution is
    available.  

    VMware         Product   Running  Replace with/
    Product        Version   on       Apply Patch
    =============  ========  =======  =================
    VirtualCenter  any       Windows  not affected

    hosted *       any       any      not affected

    ESXi           any       ESXi     not affected

    ESX            4.1       ESX      affected, patch pending
    ESX            4.0       ESX      affected, patch pending
    ESX            3.5       ESX      ESX350-201008412-SG
    ESX            3.0.3     ESX      affected, patch pending

  * hosted products are VMware Workstation, Player, ACE, Server, Fusion.

4. Solution

   Please review the patch/release notes for your product and version
   and verify the md5sum of your downloaded file.

   ESX 3.5
   -------

   ESX350-201008405-SG (cpio)
   -------------------
   http://download3.vmware.com/software/vi/ESX350-201008405-SG.zip
   md5sum: e1d5464ab9886f93dc47ffe7b50e6246
   http://kb.vmware.com/kb/1026130

   ESX350-201008407-SG (tar)
   -------------------
   http://download3.vmware.com/software/vi/ESX350-201008407-SG.zip
   md5sum: 574013a102fb523c7a97c1acb05f63ea
   http://kb.vmware.com/kb/1026132

   ESX350-201008410-SG (samba)
   -------------------
   http://download3.vmware.com/software/vi/ESX350-201008410-SG.zip
   md5sum: c5224cf4218a3636b70207b8d269d024
   http://kb.vmware.com/kb/1026134

   ESX350-201008411-SG (krb5)
   -------------------
   http://download3.vmware.com/software/vi/ESX350-201008411-SG.zip
   md5sum: c0f8b642f8eddd91c959e262d1b7f181
   http://kb.vmware.com/kb/1026135

   ESX350-201008412-SG (perl)
   -------------------
   http://download3.vmware.com/software/vi/ESX350-201008412-SG.zip
   md5sum: 30e176f34e49c055b0485dfc921fbf81
   http://kb.vmware.com/kb/1026137

5. References

   CVE numbers
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4268
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0624
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2063
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1321
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1168
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1447

- ------------------------------------------------------------------------

6. Change log

2010-08-31  VMSA-2010-0013
Initial security advisory after release of patches for ESX 3.5
on 2010-08-31

- -----------------------------------------------------------------------
7. Contact

E-mail list for product security notifications and announcements:
http://lists.vmware.com/cgi-bin/mailman/listinfo/security-announce

This Security Advisory is posted to the following lists:

  * security-announce at lists.vmware.com
  * bugtraq at securityfocus.com
  * full-disclosure at lists.grok.org.uk

E-mail:  security at vmware.com
PGP key at: http://kb.vmware.com/kb/1055

VMware Security Center
http://www.vmware.com/security

VMware security response policy
http://www.vmware.com/support/policies/security_response.html

General support life cycle policy
http://www.vmware.com/support/policies/eos.html

VMware Infrastructure support life cycle policy
http://www.vmware.com/support/policies/eos_vi.html

Copyright 2010 VMware Inc.  All rights reserved.


-----BEGIN PGP SIGNATURE-----
Version: PGP Desktop 9.8.3 (Build 4028)
Charset: utf-8

wj8DBQFMffPwS2KysvBH1xkRAvXwAJ4skfzL8KP0a0OFA3VrUwSN0zMB6wCcC/yB
xiPGukMjKtDy6B2f6/hB/LE=
=PAp4
-----END PGP SIGNATURE-----
    

- 漏洞信息 (F42752)

Ubuntu Security Notice 234-1 (PacketStormID:F42752)
2006-01-03 00:00:00
Ubuntu  security.ubuntu.com
advisory,overflow
linux,ubuntu
CVE-2005-4268
[点击下载]

Ubuntu Security Notice USN-234-1 - Richard Harms discovered that cpio did not sufficiently validate file properties when creating archives. Files with e. g. a very large size caused a buffer overflow.

===========================================================
Ubuntu Security Notice USN-234-1	   January 02, 2006
cpio vulnerability
CVE-2005-4268
===========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 4.10 (Warty Warthog)
Ubuntu 5.04 (Hoary Hedgehog)
Ubuntu 5.10 (Breezy Badger)

The following packages are affected:

cpio

The problem can be corrected by upgrading the affected package to
version 2.5-1.1ubuntu0.3 (for Ubuntu 4.10), 2.5-1.1ubuntu1.2 (for
Ubuntu 5.04), or 2.5-1.2ubuntu1.1 (for Ubuntu 5.10).  In general, a
standard system upgrade is sufficient to effect the necessary changes.

Details follow:

Richard Harms discovered that cpio did not sufficiently validate file
properties when creating archives. Files with e. g. a very large size
caused a buffer overflow. By tricking a user or an automatic backup
system into putting a specially crafted file into a cpio archive, a
local attacker could probably exploit this to execute arbitrary code
with the privileges of the target user (which is likely root in an
automatic backup system).


Updated packages for Ubuntu 4.10:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu0.3.diff.gz
      Size/MD5:    27861 30d956e1d7c6169dd30bcf4f85e198ec
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu0.3.dsc
      Size/MD5:      551 9cca8af73c1661423f75b5ca39dc3fd5
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5.orig.tar.gz
      Size/MD5:   185480 e02859af1bbbbd73fcbf757acb57e0a4

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu0.3_amd64.deb
      Size/MD5:    68856 253028eac0406c5742831edd9f7cc2e7

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu0.3_i386.deb
      Size/MD5:    64370 96ef06af0acb7eba610bab20b6552aa8

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu0.3_powerpc.deb
      Size/MD5:    67910 2b3012a5c0529d6589d779285455e444

Updated packages for Ubuntu 5.04:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu1.2.diff.gz
      Size/MD5:    27858 6d167bf59160bb49a356ad63aaf46ddd
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu1.2.dsc
      Size/MD5:      551 671b6542bb14aff13d27c5ff20e048e8
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5.orig.tar.gz
      Size/MD5:   185480 e02859af1bbbbd73fcbf757acb57e0a4

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu1.2_amd64.deb
      Size/MD5:    68910 1fa1ee8b327076ac4f7ba78c4f31f46d

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu1.2_i386.deb
      Size/MD5:    64192 a7fb45e72550bc1d5ec14bb073ffc000

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.1ubuntu1.2_powerpc.deb
      Size/MD5:    67938 3128b5006e24b0ab36fe8658b27bd15e

Updated packages for Ubuntu 5.10:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.2ubuntu1.1.diff.gz
      Size/MD5:    27910 67535b38785a093b63e96989d15ce73b
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.2ubuntu1.1.dsc
      Size/MD5:      551 4831459b57acf5981235835a47f9e91b
    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5.orig.tar.gz
      Size/MD5:   185480 e02859af1bbbbd73fcbf757acb57e0a4

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.2ubuntu1.1_amd64.deb
      Size/MD5:    70568 cb8fa678380262c7f36a5eca7f75a8bf

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.2ubuntu1.1_i386.deb
      Size/MD5:    64630 882a2257d4658556bd0782f51ce49884

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.5-1.2ubuntu1.1_powerpc.deb
      Size/MD5:    68776 1d761237abc915aa6bdd3b5d7ad5e5f3
    

- 漏洞信息

22194
cpio on 64-bit Large File Size Handling Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-07 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站