CVE-2005-4214
CVSS5.0
发布时间 :2005-12-14 06:03:00
修订时间 :2011-08-10 00:00:00
NMCO    

[原文]phpCOIN 1.2.2 allows remote attackers to obtain the installation path via a direct request to config.php, which leaks the path in an error message because the _CCFG['_PKG_PATH_DBSE'] variable is not defined.


[CNNVD]phpCOIN出错信息漏洞(CNNVD-200512-245)

        phpCOIN 1.2.2 使得远程攻击者可以通过直接请求config.php获取安装路径,由于未定义_CCFG['_PKG_PATH_DBSE']变量,因此在出错信息泄露了路径。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-200 [信息暴露]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4214
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4214
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-245
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2888
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2888
http://www.securityfocus.com/archive/1/archive/1/419382/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051213 phpCOIN 1.2.2 multiple vulnerabilities
http://www.osvdb.org/21726
(UNKNOWN)  OSVDB  21726
http://securitytracker.com/id?1015345
(UNKNOWN)  SECTRACK  1015345
http://secunia.com/advisories/18030
(VENDOR_ADVISORY)  SECUNIA  18030
http://rgod.altervista.org/phpcoin122.html
(VENDOR_ADVISORY)  MISC  http://rgod.altervista.org/phpcoin122.html
http://rgod.altervista.org/phpcoin_122_sql_xpl.html
(UNKNOWN)  MISC  http://rgod.altervista.org/phpcoin_122_sql_xpl.html
http://forums.phpcoin.com/index.php?showtopic=5469
(UNKNOWN)  CONFIRM  http://forums.phpcoin.com/index.php?showtopic=5469

- 漏洞信息

phpCOIN出错信息漏洞
中危 未知
2005-12-14 00:00:00 2006-03-29 00:00:00
远程  
        phpCOIN 1.2.2 使得远程攻击者可以通过直接请求config.php获取安装路径,由于未定义_CCFG['_PKG_PATH_DBSE']变量,因此在出错信息泄露了路径。

- 公告与补丁

        

- 漏洞信息

21726
phpCOIN config.php Direct Request Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

phpCOIN contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a remote attacker makes a direct request to the 'config.php' script, which will disclose the software's installation path resulting in a loss of confidentiality. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks.

- 时间线

2005-12-12 Unknow
2005-12-12 Unknow

- 解决方案

Upgrade to version 1.2.2 (2005-12-13) or higher, as it has been reported to fix this vulnerability. Note that this flaw was fixed in the 2005-12-13 release without a change in version number. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站