CVE-2005-4212
CVSS5.0
发布时间 :2005-12-14 06:03:00
修订时间 :2011-03-07 21:27:51
NMCO    

[原文]Directory traversal vulnerability in coin_includes/db.php in phpCOIN 1.2.2 allows remote attackers to read arbitrary local files via ".." (dot dot) sequences in the $_CCFG[_PKG_PATH_DBSE] variable.


[CNNVD]PHPCoin Config.PHP 目录遍历漏洞(CNNVD-200512-287)

        phpCOIN 1.2.2 中的coin_includes/db.php存在目录遍历漏洞,远程攻击者可以通过在$_CCFG[_PKG_PATH_DBSE] 变量中的 ".." (参数中包含'..')序列读取任意本地文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4212
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4212
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-287
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/2888
(UNKNOWN)  VUPEN  ADV-2005-2888
http://www.securityfocus.com/bid/15831
(UNKNOWN)  BID  15831
http://www.securityfocus.com/archive/1/archive/1/419382/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051213 phpCOIN 1.2.2 multiple vulnerabilities
http://securitytracker.com/id?1015345
(UNKNOWN)  SECTRACK  1015345
http://secunia.com/advisories/18030
(VENDOR_ADVISORY)  SECUNIA  18030
http://rgod.altervista.org/phpcoin122.html
(VENDOR_ADVISORY)  MISC  http://rgod.altervista.org/phpcoin122.html
http://forums.phpcoin.com/index.php?showtopic=5469
(UNKNOWN)  CONFIRM  http://forums.phpcoin.com/index.php?showtopic=5469

- 漏洞信息

PHPCoin Config.PHP 目录遍历漏洞
中危 路径遍历
2005-12-14 00:00:00 2006-03-29 00:00:00
远程  
        phpCOIN 1.2.2 中的coin_includes/db.php存在目录遍历漏洞,远程攻击者可以通过在$_CCFG[_PKG_PATH_DBSE] 变量中的 ".." (参数中包含'..')序列读取任意本地文件。

- 公告与补丁

        

- 漏洞信息

57538
phpCOIN coin_includes/db.php $_CCFG[_PKG_PATH_DBSE] Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Unknown Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

phpCOIN contains a flaw that allows a remote attacker to read files outside of the web path. The issue is due to the coin_includes/db.php not properly sanitizing user input, specifically directory traversal style attacks (../../) supplied via the '$_CCFG[_PKG_PATH_DBSE] parameter(s).

- 时间线

2005-12-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站