CVE-2005-4162
CVSS4.3
发布时间 :2005-12-11 06:03:00
修订时间 :2011-03-07 21:27:47
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in cal_make.pl in ACME PerlCal 2.99.20 allows remote attackers to inject arbitrary web script or HTML via the p0 parameter.


[CNNVD]ACME Perl-Cal Cal_make.PL 跨站脚本漏洞(CNNVD-200512-215)

        ACME PerlCal 2.99.20的cal_make.pl中存在跨站脚本攻击漏洞。远程攻击者可以借助p0参数,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:acme_labs:perlcal:2.99.30
cpe:/a:acme_labs:perlcal:2.99
cpe:/a:acme_labs:perlcal:2.99.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4162
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4162
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-215
(官方数据源) CNNVD

- 其它链接及资源

http://www.perlcal.com/calendar/docs/bugs.txt
(PATCH)  CONFIRM  http://www.perlcal.com/calendar/docs/bugs.txt
http://xforce.iss.net/xforce/xfdb/23534
(UNKNOWN)  XF  perlcal-calmake-xss(23534)
http://www.vupen.com/english/advisories/2005/2810
(UNKNOWN)  VUPEN  ADV-2005-2810
http://www.securityfocus.com/bid/15779
(UNKNOWN)  BID  15779
http://www.osvdb.org/21540
(UNKNOWN)  OSVDB  21540
http://securitytracker.com/id?1015332
(UNKNOWN)  SECTRACK  1015332
http://secunia.com/advisories/17953
(VENDOR_ADVISORY)  SECUNIA  17953
http://archives.neohapsis.com/archives/fulldisclosure/2005-12/0315.html
(UNKNOWN)  FULLDISC  20051208 Perl cal XSS Vulnerability

- 漏洞信息

ACME Perl-Cal Cal_make.PL 跨站脚本漏洞
中危 跨站脚本
2005-12-11 00:00:00 2006-08-03 00:00:00
远程  
        ACME PerlCal 2.99.20的cal_make.pl中存在跨站脚本攻击漏洞。远程攻击者可以借助p0参数,注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

21540
PerlCal cal_make.pl p0 Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PerlCal contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'p0' variable upon submission to the 'cal_make_.pl' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-12-08 2005-11-23
2005-12-08 Unknow

- 解决方案

Upgrade to version 2.99.30 or higher, as it has been reported to fix this vulnerability. In addition, Acme Software has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站