发布时间 :2005-12-10 21:03:00
修订时间 :2011-04-12 00:00:00

[原文]Unspecified vulnerability in PEAR installer 1.4.2 and earlier allows user-assisted attackers to execute arbitrary code via a crafted package that can execute code when the pear command is executed or when the Web/Gtk frontend is loaded.

[CNNVD]PEAR installer 未明漏洞(CNNVD-200512-188)

        PEAR installer 1.4.2及更早版本中存在未明漏洞,需要用户协助的攻击者可以通过可在执行pear命令时或载入Web/Gtk前端时执行代码的特制程序包来执行任意代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php:pear:1.4.0a5PHP PEAR 1.4.0a5
cpe:/a:php:pear:1.3b3PHP PEAR 1.3b3
cpe:/a:php:pear:1.4.0:rc1PHP PEAR 1.4.0RC1
cpe:/a:php:pear:0.10PHP PEAR 0.10
cpe:/a:php:pear:1.4.0a8PHP PEAR 1.4.0a8
cpe:/a:php:pear:1.4.0a7PHP PEAR 1.4.0a7
cpe:/a:php:pear:1.2b1PHP PEAR 1.2b1
cpe:/a:php:pear:1.4.1PHP PEAR 1.4.1
cpe:/a:php:pear:1.0PHP PEAR 1.0
cpe:/a:php:pear:1.3.4PHP PEAR 1.3.4
cpe:/a:php:pear:1.3.1PHP PEAR 1.3.1
cpe:/a:php:pear:1.3b5PHP PEAR 1.3b5
cpe:/a:php:pear:1.2b2PHP PEAR 1.2b2
cpe:/a:php:pear: PEAR
cpe:/a:php:pear:1.4.0:rc2PHP PEAR 1.4.0RC2
cpe:/a:php:pear:1.3b1PHP PEAR 1.3b1
cpe:/a:php:pear:1.3.5PHP PEAR 1.3.5
cpe:/a:php:pear:1.2.1PHP PEAR 1.2.1
cpe:/a:php:pear:1.4.0a1PHP PEAR 1.4.0a1
cpe:/a:php:pear:1.3.3PHP PEAR 1.3.3
cpe:/a:php:pear:1.4.0a2PHP PEAR 1.4.0a2
cpe:/a:php:pear:1.0b3PHP PEAR 1.0b3
cpe:/a:php:pear:1.4.0a6PHP PEAR 1.4.0a6
cpe:/a:php:pear:1.2b5PHP PEAR 1.2b5
cpe:/a:php:pear:1.3b6PHP PEAR 1.3b6
cpe:/a:php:pear:0.9PHP PEAR 0.9
cpe:/a:php:pear:1.4.0a9PHP PEAR 1.4.0a9
cpe:/a:php:pear:1.4.0a3PHP PEAR 1.4.0a3
cpe:/a:php:pear:1.4.2PHP PEAR 1.4.2
cpe:/a:php:pear:1.4.0PHP PEAR 1.4.0
cpe:/a:php:pear:1.4.0a11PHP PEAR 1.4.0a11
cpe:/a:php:pear:1.2PHP PEAR 1.2
cpe:/a:php:pear:1.0b2PHP PEAR 1.0b2
cpe:/a:php:pear:1.0.1PHP PEAR 1.0.1
cpe:/a:php:pear:0.90PHP PEAR 0.90
cpe:/a:php:pear:0.11PHP PEAR 0.11
cpe:/a:php:pear:1.3.6PHP PEAR 1.3.6
cpe:/a:php:pear:1.4.0a10PHP PEAR 1.4.0a10
cpe:/a:php:pear:1.4.0a12PHP PEAR 1.4.0a12
cpe:/a:php:pear:1.3PHP PEAR 1.3
cpe:/a:php:pear:1.2b4PHP PEAR 1.2b4
cpe:/a:php:pear:1.1PHP PEAR 1.1
cpe:/a:php:pear:1.3b2PHP PEAR 1.3b2
cpe:/a:php:pear:1.4.0a4PHP PEAR 1.4.0a4
cpe:/a:php:pear:1.2b3PHP PEAR 1.2b3
cpe:/a:php:pear:1.0b1PHP PEAR 1.0b1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  XF  pear-installer-code-execution(23021)
(PATCH)  SECTRACK  1015161

- 漏洞信息

PEAR installer 未明漏洞
中危 未知
2005-12-10 00:00:00 2006-08-28 00:00:00
        PEAR installer 1.4.2及更早版本中存在未明漏洞,需要用户协助的攻击者可以通过可在执行pear命令时或载入Web/Gtk前端时执行代码的特制程序包来执行任意代码。

- 公告与补丁


- 漏洞信息

PEAR Installer Crafted Package Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-11-04 2005-11-01
Unknow Unknow

- 解决方案

Upgrade to version 1.4.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete