CVE-2005-4138
CVSS4.3
发布时间 :2005-12-09 10:03:00
修订时间 :2008-09-05 16:56:08
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in ThWboard before 3 Beta 2.84 allow remote attackers to inject arbitrary web script or HTML via the (1) Wohnort and (2) Beruf fields in editprofile.php, (3) user parameter array in v_profile.php, and (4) the action parameter in misc.php.


[CNNVD]ThWboard多个跨站脚本攻击漏洞(CNNVD-200512-168)

        ThWboard 3 Beta 2.84之前版本中存在多个跨站脚本攻击漏洞,远程攻击者可以通过以下方式注入任意Web脚本或HTML:editprofile.php中的(1) Wohnort和(2) Beruf字段,(3) v_profile.php中的user参数数组,以及(4)misc.php中的action参数。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4138
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4138
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-168
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15763
(PATCH)  BID  15763
http://www.securityfocus.com/archive/1/archive/1/418837/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051207 BUGTRAQ:20051207 [KAPDA::#15] - ThWboard multiple vulnerabilities
http://kapda.ir/advisory-149.html
(VENDOR_ADVISORY)  MISC  http://kapda.ir/advisory-149.html

- 漏洞信息

ThWboard多个跨站脚本攻击漏洞
中危 跨站脚本
2005-12-09 00:00:00 2005-12-09 00:00:00
远程  
        ThWboard 3 Beta 2.84之前版本中存在多个跨站脚本攻击漏洞,远程攻击者可以通过以下方式注入任意Web脚本或HTML:editprofile.php中的(1) Wohnort和(2) Beruf字段,(3) v_profile.php中的user参数数组,以及(4)misc.php中的action参数。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/thwb/thwb-300-beta-2.84-php5.tar.gz

- 漏洞信息

21740
ThWboard editprofile.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

ThWboard contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the 'Beruf' and 'Wohnort' fields upon submission to the 'editprofile.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-12-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3 beta 2.84 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站