CVE-2005-4031
CVSS7.5
发布时间 :2005-12-06 06:03:00
修订时间 :2011-03-07 21:27:34
NMCO    

[原文]Eval injection vulnerability in MediaWiki 1.5.x before 1.5.3 allows remote attackers to execute arbitrary PHP code via the "user language option," which is used as part of a dynamic class name that is processed using the eval function.


[CNNVD]MediaWiki Eval注入漏洞(CNNVD-200512-109)

        MediaWiki 1.5.3之前的1.5.x版本中存在Eval注入漏洞,远程攻击者可以通过"用户语言选项"(用作通过eval函数保护的动态类名的一部分)执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.5_beta2
cpe:/a:mediawiki:mediawiki:1.5_beta3
cpe:/a:mediawiki:mediawiki:1.5_alpha1
cpe:/a:mediawiki:mediawiki:1.5.0MediaWiki 1.5.0
cpe:/a:mediawiki:mediawiki:1.5.1MediaWiki 1.5.1
cpe:/a:mediawiki:mediawiki:1.5_beta1
cpe:/a:mediawiki:mediawiki:1.5.2MediaWiki 1.5.2
cpe:/a:mediawiki:mediawiki:1.5_alpha2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4031
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4031
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-109
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/392156
(UNKNOWN)  CERT-VN  VU#392156
http://www.securityfocus.com/bid/15703
(PATCH)  BID  15703
http://sourceforge.net/project/shownotes.php?group_id=34373&release_id=375755
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=34373&release_id=375755
http://secunia.com/advisories/17866
(VENDOR_ADVISORY)  SECUNIA  17866
http://www.vupen.com/english/advisories/2005/2726
(UNKNOWN)  VUPEN  ADV-2005-2726

- 漏洞信息

MediaWiki Eval注入漏洞
高危 输入验证
2005-12-06 00:00:00 2007-01-03 00:00:00
远程  
        MediaWiki 1.5.3之前的1.5.x版本中存在Eval注入漏洞,远程攻击者可以通过"用户语言选项"(用作通过eval函数保护的动态类名的一部分)执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/wikipedia/mediawiki-1.5.3.tar.gz

- 漏洞信息

21444
MediaWiki Language Option eval() Function Arbitrary PHP Code Execution
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-12-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站