CVE-2005-4030
CVSS5.1
发布时间 :2005-12-06 06:03:00
修订时间 :2011-03-07 21:27:34
NMCO    

[原文]SQL injection vulnerability in Quicksilver Forums before 1.5.1 allows remote attackers to execute arbitrary SQL commands via the HTTP_USER_AGENT header.


[CNNVD]Quicksilver Forums SQL注入漏洞(CNNVD-200512-108)

        Quicksilver Forums 1.5.1之前版本中存在SQL注入漏洞,远程攻击者可以通过HTTP_USER_AGENT头执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4030
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4030
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-108
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=375970&group_id=154354
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=375970&group_id=154354
http://secunia.com/advisories/17861
(VENDOR_ADVISORY)  SECUNIA  17861
http://www.vupen.com/english/advisories/2005/2729
(UNKNOWN)  VUPEN  ADV-2005-2729
http://www.securityfocus.com/bid/15710
(UNKNOWN)  BID  15710
http://www.osvdb.org/21443
(UNKNOWN)  OSVDB  21443

- 漏洞信息

Quicksilver Forums SQL注入漏洞
中危 SQL注入
2005-12-06 00:00:00 2005-12-06 00:00:00
远程  
        Quicksilver Forums 1.5.1之前版本中存在SQL注入漏洞,远程攻击者可以通过HTTP_USER_AGENT头执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/qsforums/quicksilverforums-1.1.5.tar.gz?download

- 漏洞信息

21443
Quicksilver Forums HTTP_USER_AGENT SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Quicksilver Forums contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the input passed to HTTP_USER_AGENT header not being properly sanitized. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站