CVE-2005-4022
CVSS4.3
发布时间 :2005-12-05 06:03:00
修订时间 :2011-03-07 21:27:33
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the "Add Image From Web" feature in Gallery 2.0 before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via Javascript in an IMG tag.


[CNNVD]Gallery多个输入验证漏洞(CNNVD-200512-097)

        Gallery 2.0 before 2.0.2之前的2.0 版本的"Add Image From Web" 功能存在跨站脚本攻击漏洞。远程攻击者可以借助 IMG标签中的Javascript,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4022
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4022
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-097
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/418200/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051130 Gallery 2.x Security Advisory
http://www.osvdb.org/21221
(VENDOR_ADVISORY)  OSVDB  21221
http://secunia.com/advisories/17747
(VENDOR_ADVISORY)  SECUNIA  17747
http://www.vupen.com/english/advisories/2005/2681
(UNKNOWN)  VUPEN  ADV-2005-2681
http://www.securityfocus.com/bid/15614
(UNKNOWN)  BID  15614

- 漏洞信息

Gallery多个输入验证漏洞
中危 跨站脚本
2005-12-05 00:00:00 2005-12-05 00:00:00
远程  
        Gallery 2.0 before 2.0.2之前的2.0 版本的"Add Image From Web" 功能存在跨站脚本攻击漏洞。远程攻击者可以借助 IMG标签中的Javascript,注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://codex.gallery2.org/index.php?title=Gallery2:Download&oldid=5917

- 漏洞信息

21221
Gallery Add Image From Web XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Gallery contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the remote image url upon submission to the "Add Image From Web" feature. This could allow a user to create a specially crafted page that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-11-29 Unknow
2005-11-29 Unknow

- 解决方案

Upgrade to version 2.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站