CVE-2005-4003
CVSS7.5
发布时间 :2005-12-04 19:03:00
修订时间 :2008-09-20 00:41:35
NMCO    

[原文]Multiple SQL injection vulnerabilities in Absolute Shopping Package Solutions (ASPS) Shopping Cart Professional 2.9d and earlier, and Lite 2.1 and earlier, allow remote attackers to execute arbitrary SQL commands via the (1) srch_product_name parameter to adv_search.asp and (2) b_search parameter to bsearch.asp. NOTE: the original disclosure was specifically only for an XSS issue, but the CVE description was for SQL injection. Since the original disclosure, SQL injection vectors have been reported. This CVE might be REJECTed or significantly altered pending additional information.


[CNNVD]Absolute Shopping Package Solutions Shopping Cart 多个SQL注入漏洞(CNNVD-200512-058)

        Absolute Shopping Package Solutions (ASPS) Shopping Cart Professional 2.9d及之前版本,以及Lite 2.1及之前版本存在多个SQL注入漏洞。远程攻击者可以借助(1)对adv_search.asp 的 srch_product_name参数和 (2) b对bsearch.asp的 b_search 参数,执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:asps:shopping_cart:2.1::lite
cpe:/a:asps:shopping_cart:2.9d::professional

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4003
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-4003
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-058
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15694
(UNKNOWN)  BID  15694
http://pridels0.blogspot.com/2005/12/asps-shopping-cart-professional-and.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2005/12/asps-shopping-cart-professional-and.html

- 漏洞信息

Absolute Shopping Package Solutions Shopping Cart 多个SQL注入漏洞
高危 SQL注入
2005-12-04 00:00:00 2006-06-09 00:00:00
远程  
        Absolute Shopping Package Solutions (ASPS) Shopping Cart Professional 2.9d及之前版本,以及Lite 2.1及之前版本存在多个SQL注入漏洞。远程攻击者可以借助(1)对adv_search.asp 的 srch_product_name参数和 (2) b对bsearch.asp的 b_search 参数,执行任意SQL指令。

- 公告与补丁

        

- 漏洞信息

21490
ASPS Shopping Cart adv_search.asp srch_product_name Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Discontinued Product
Exploit Public Vendor Verified, Uncoordinated Disclosure

- 漏洞描述

ASPS Shopping Cart contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the 'srch_product_name' parameter upon submission to the 'adv_search.asp' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-12-03 Unknow
2005-12-03 Unknow

- 解决方案

The vendor has discontinued this product and therefore has no patch or upgrade that mitigates this problem. It is recommended that an alternate software package be used in its place.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站