CVE-2005-3984
CVSS7.5
发布时间 :2005-12-04 06:03:00
修订时间 :2011-08-05 00:00:00
NMCO    

[原文]SQL injection vulnerability in WebCalendar 1.0.1 allows remote attackers to execute arbitrary SQL commands via the time_range parameter to edit_report_handler.php. NOTE: the startid/activity_log.php vector is already covered by CVE-2005-3949.


[CNNVD]WebCalendar SQL注入漏洞(CNNVD-200512-069)

        WebCalendar 1.0.1版本存在SQL注入漏洞。远程攻击者可以借助对 time_range 参数,执行任意的SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3984
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3984
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-069
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/17848
(VENDOR_ADVISORY)  SECUNIA  17848
http://www.vupen.com/english/advisories/2005/2702
(VENDOR_ADVISORY)  VUPEN  ADV-2005-2702
http://www.securityfocus.com/archive/1/archive/1/418286/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051201 WebCalendar Multiple Vulnerabilities.
http://www.osvdb.org/21382
(UNKNOWN)  OSVDB  21382
http://vd.lwang.org/webcalendar_multiple_vulns.txt
(VENDOR_ADVISORY)  MISC  http://vd.lwang.org/webcalendar_multiple_vulns.txt

- 漏洞信息

WebCalendar SQL注入漏洞
高危 SQL注入
2005-12-04 00:00:00 2006-06-09 00:00:00
远程  
        WebCalendar 1.0.1版本存在SQL注入漏洞。远程攻击者可以借助对 time_range 参数,执行任意的SQL指令。

- 公告与补丁

        

- 漏洞信息

21382
WebCalendar edit_report_handler.php time_range Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

WebCalendar contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the edit_report_handler.php script not properly sanitizing user-supplied input to the 'time_range' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站