发布时间 :2005-12-04 06:03:00
修订时间 :2011-03-07 21:27:30

[原文]CRLF injection vulnerability in layers_toggle.php in WebCalendar 1.0.1 might allow remote attackers to modify HTTP headers and conduct HTTP response splitting attacks via the ret parameter, which is used to redirect URL requests.

[CNNVD]WebCalendar Layers_Toggle.PHP HTTP 响应拆分漏洞(CNNVD-200512-056)

        WebCalendar 1.0.1的layers_toggle.php中存在CRLF注入漏洞。远程攻击者可以通过可重定向URL请求的ret参数,修改HTTP header并进行HTTP响应拆分攻击。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2005-2702
(UNKNOWN)  BID  15673
(UNKNOWN)  BUGTRAQ  20051201 WebCalendar Multiple Vulnerabilities.

- 漏洞信息

WebCalendar Layers_Toggle.PHP HTTP 响应拆分漏洞
中危 输入验证
2005-12-04 00:00:00 2006-06-09 00:00:00
        WebCalendar 1.0.1的layers_toggle.php中存在CRLF注入漏洞。远程攻击者可以通过可重定向URL请求的ret参数,修改HTTP header并进行HTTP响应拆分攻击。

- 公告与补丁


- 漏洞信息

WebCalendar layers_toggle.php ret Variable HTTP Response Splitting
Remote / Network Access Input Manipulation
Impact Unknown
Exploit Unknown

- 漏洞描述

WebCalendar contains a flaw that allows an HTTP response splitting vulnerability. This flaw exists because the application does not validate parameter '$ret' upon submission to the 'layers_toggle.php' script. This could allow a user to create a specially crafted URL that would influence or misrepresent how Web content is served, cached or interpreted, leading to a loss of integrity.

- 时间线

2005-12-01 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, WebCalendar has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

WebCalendar Layers_Toggle.PHP HTTP Response Splitting Vulnerability
Input Validation Error 15673
Yes No
2005-12-01 12:00:00 2006-12-15 09:03:00 is credited with the discovery of this vulnerability.

- 受影响的程序版本

k5n WebCalendar 1.0.1
k5n WebCalendar 0.1 .0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

WebCalendar is prone to an HTTP response-splitting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

A remote attacker may exploit this vulnerability to influence or misrepresent how web content is served, cached, or interpreted. This could aid in various attacks that attempt to entice client users into a false sense of trust.

WebCalendar 1.0.1 is vulnerable; other versions may also be affected.

- 漏洞利用

An exploit is not required.

An example URI has been provided:[url_redirect_to]

- 解决方案

Please see the references for vendor advisories and more information.

- 相关参考