CVE-2005-3980
CVSS7.5
发布时间 :2005-12-04 06:03:00
修订时间 :2011-03-07 21:27:28
NMCO    

[原文]SQL injection vulnerability in the ticket query module in Edgewall Trac 0.9 and possibly earlier allows remote attackers to execute arbitrary SQL commands via the group parameter.


[CNNVD]Edgewall Trac Ticket Query Module SQL注入漏洞(CNNVD-200512-054)

        Edgewall Trac 0.9及可能的之前版本的ticket query module存在SQL注入漏洞。远程攻击者可以通过group参数执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:edgewall_software:trac:0.50.9
cpe:/a:edgewall_software:trac:0.9
cpe:/a:edgewall_software:trac:0.8.2
cpe:/a:edgewall_software:trac:0.8
cpe:/a:edgewall_software:trac:0.7.1
cpe:/a:edgewall_software:trac:0.5.2
cpe:/a:edgewall_software:trac:0.6
cpe:/a:edgewall_software:trac:0.5.1
cpe:/a:edgewall_software:trac:0.7
cpe:/a:edgewall_software:trac:0.9b1
cpe:/a:edgewall_software:trac:0.9b2
cpe:/a:edgewall_software:trac:0.8.1
cpe:/a:edgewall_software:trac:0.8.3
cpe:/a:edgewall_software:trac:0.8.4
cpe:/a:edgewall_software:trac:0.6.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3980
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-3980
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200512-054
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/15676/
(PATCH)  BID  15676
http://www.securityfocus.com/archive/1/archive/1/418294/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20051201 Edgewall Trac SQL Injection Vulnerability
http://securitytracker.com/id?1015302
(VENDOR_ADVISORY)  SECTRACK  1015302
http://secunia.com/advisories/17836/
(VENDOR_ADVISORY)  SECUNIA  17836
http://www.vupen.com/english/advisories/2005/2701
(UNKNOWN)  VUPEN  ADV-2005-2701
http://projects.edgewall.com/trac/wiki/ChangeLog
(UNKNOWN)  CONFIRM  http://projects.edgewall.com/trac/wiki/ChangeLog
http://xforce.iss.net/xforce/xfdb/23461
(UNKNOWN)  XF  trac-query-sql-injection(23461)
http://www.osvdb.org/21386
(UNKNOWN)  OSVDB  21386

- 漏洞信息

Edgewall Trac Ticket Query Module SQL注入漏洞
高危 SQL注入
2005-12-04 00:00:00 2005-12-06 00:00:00
远程  
        Edgewall Trac 0.9及可能的之前版本的ticket query module存在SQL注入漏洞。远程攻击者可以通过group参数执行任意SQL指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        ftp://ftp.edgewall.com/pub/trac/trac-0.9.1.tar.gz

- 漏洞信息

21386
Trac Ticket Query Module group Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Trac contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the query script not properly sanitizing user-supplied input to the group variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站